How do I take these frames out?

  • Author
    Posts
  • #412305

    rmprado
    Member

    My layout automatically puts frames around every image I post on my blog. Is there a way to negate that on a single image? I’ve tried messing with the HTML code, inside the IMG tag, without success.

    Can anybody help me?

    The blog I need help with is cinecartografo.wordpress.com.

    #412415

    tellyworth
    Staff

    That’s an intentional part of the design by the theme designer.

    You can either choose a different theme, or use the CSS upgrade with a rule something like this (untested):


    div.entry-content img { border: none; }

    #412416

    devblog
    Member

    .entry-content img { border: none; }

    Should suffice

    #412417

    tellyworth
    Staff

    @devblog not necessarily because it needs specificity to override the theme rule. I’m not sure if mine is sufficient either.

    #412420

    raincoaster
    Member

    I always get a weird framelike structure on my images IF I use the Caption code. If I strip it out, it disappears. Try that.

    #412425

    devblog
    Member

    not necessarily because it needs specificity to override the theme rule. I’m not sure if mine is sufficient either.

    Any custom CSS that is sent by wordpress is appended at the bottom of the original CSS, therefore, the custom CSS overrides the default one.

    If the default CSS had a definition like this:

    div.entry-content img {border: solid 1px #000;}

    Then my solution wouldn’t work, but yours. An !important rule would even be needed.
    But if the original definitions is like this:

    .entry-content img {border: solid 1px #000;}

    Then adding the div selector is just an overkill.

    #412448

    Visual post editor: click image, click mountain icon, click Advanced Settings, write 0 in the Border box, Update, Update post. Same thing with border:0 in the html.

The topic ‘How do I take these frames out?’ is closed to new replies.