How do I update the theme?

  • Author
    Posts
  • #3300746

    I have a problem with the edit window–it provides white text on a white background. I’ve read online that I can fix this by updating my theme, but I don’t know how to do so and I can’t find anything online to help. Can you please tell me how to update the theme? I’m using Twenty Ten.

    The blog I need help with is cassandrastout.wordpress.com.

    #3300982

    Hi cassandrastout,

    I looked at cassandrastout.wordpress.com through your account but couldn’t see any white text on a white background. It would be great if you could make a screenshot of where this is happening and upload it to your Media Library.

    Also, does the problem only occur on a particular post or page, or all of the ones you are editing?

    Once a theme is activated on a WordPress.com site, any updates we release are automatically added, so it’s not something you need to do manually.

    Thanks!

    #3301093

    Thanks for your quick response! The issue occurs in every post I’m editing. The window looks blank, but I can select the text with Ctrl + A and copy it with Ctrl + C, though the text doesn’t show up highlighted. I cleared my cache, erased my cookies, and changed my theme entirely, but nothing seems to help. The problem happens in both Edge and Internet Explorer. I haven’t tried Firefox yet.

    I will take a screenshot soon, but all you will see is the title of a blank post.

    #3301156

    No worries, the screen shot will still be useful. I’ll watch for it in your next reply.

    #3301744

    I’ve uploaded a screenshot of the problem to my Media Library. One draft, “Common Pitfalls When Communicating With Your Kids About Your Bipolar Disorder, part II,” has the issue, while the other drafts, when checked on my desktop and mobile phone, don’t. I haven’t checked them on my laptop yet. I copied the text from the post and pasted it into a new post, and the new post has the issue. I don’t know why it’s not working, and I don’t know how to approach the problem. Like I said, I’ve cleared my cache, cleared my cookies, and changed my theme entirely, and nothing helps.

    Thanks for your help!

    #3301745

    Also, I’ve tried Firefox, Chrome, Internet Explorer, and Edge, all with the same results.

    #3301749

    Interestingly, I can open a new edit window and start typing, and the text shows up as black on a white background. Maybe it’s limited to that one post? There was a previous post that this happened to which I lost because I started typing while all of the text was selected, which is what kicked off my searching the forums.

    #3301808

    supernovia
    Staff

    Hi cassandrastout, focusing just on that draft post you mentioned: if you click HTML and Visual and click back, does the view change at all?

    #3301827

    Nope, clicking back and forth doesn’t change anything.

    #3301836

    supernovia
    Staff

    Very odd. Can you tell me whether you have the same issue if you click to edit the post here?

    I noticed you’re using the Block Editor. You can also try clicking the three dots int the upper right and choosing Classic Editor, too, to see if you have the same issue.

    #3301838

    Now all the posts are working in the Block Editor. Weird. I was able to see the text in all the posts in the link you provided, too. I haven’t tried the block editor, actually–I was working with the classic editor. But the text shows up in the block editor, too.

    So weird. I hope that the posts continue to work. I guess we can consider this topic resolved? Thanks for all of your help!

    #3301887

    supernovia
    Staff

    @cassandrastout that is very bizarre. When I first clicked that post I saw the blankness too, but clicking the tab “fixed” it and then I couldn’t get to break again to see what was going wrong.

    Sounds like something similar happened on your end too – maybe just a bit of glitchy code that was fixed but needed a nudge to get re-downloaded? Honestly I’m not sure. But I’m glad it’s working!

    We’ll leave this open for a few days in case you run into this again. If you run into it down the road, just let us know it happened before and we can find this thread. Cheers!

    #3301897

    Awesome, thanks. I will monitor the posts and let you know if it happens again. Thanks for the quick responses!

You must be logged in to reply to this topic.