How do you remove widgets?

  • Author
  • #313287


    I accidentally added a widget to my sidebar – and now I can’t get rid of the damn thing. There seem to be several other threads on here where people report the same problem, but all of them have been closed.

    So, I followed all of the instructions on the other threads – I’ve tried dragging the widget to each and every available pixel of screen space. I’ve dragged quickly, I’ve dragged slowly. I’ve tried to fool WordPress by dragging outside the browser window and then back in again. Whatever I do, the damn thing won’t go away.

    I’ve even tried firing up different browsers to do it, but the problem is the same whether I use Firefox or IE.

    Who will rid me of this troublesome widget?

    Whoever dreamt up this crazy interface challenge should be taken out and shot. What on earth is wrong with a text link saying “delete”, or a nice little “X” icon? Pretty much everything else in the WordPress admin interface seems damn-near perfect, so why has widget removal been turned into a dexterity test (one which, I should add, gets pretty painful after a while for someone who suffers from RSI).




    It is there. Click on edit, then at the bottom right, click on remove. (You are reading old instructions, BTW. The best place to look for instructions is to click on the support link at the top.)



    Clicked on edit, nothing happened :( – it just flickers and then stays as it is.



    Strange – I added more widgets, and now the Edit link brings up a Remove button, as you say. It wasn’t working with only two widgets on there: tried it a great many times but Edit didn’t open it out. I still think it would be much better to have the Remove link visible on or alongside the widget, rather than having to “Edit” it to remove.


    just experiencig same problem and agree that easier removal should be the standard.


    I’m having real problems removing some widgets I added on the freshy theme. At first I could edit and remove by clicking the edit button on widgets, now the button just flickers and nothing happens. if i try to drag the widget nothing happens either. i’ve tried changing themes and back again, and adding more widgets, but all to no avail. i’m now left with widgets for: author, categories (twice), top clicks, and recent posts, that I don’t want. HELP!



    That flickering business happened with me too. Try it again. Click Save Changes and go back, and try Edit again and really hang on it. The box will open.

The topic ‘How do you remove widgets?’ is closed to new replies.