how do you report a bug on wordpress

  • Author
  • #1491938

    export of blog WILL NOT import to site

    The blog I need help with is



    Please confirm the URL(s). I’ll tag this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.


    Hi, thank you for your message.
    My blog is:

    I have been trying to import my blog – — into my new site –

    I followed the instruction and exported my blog as a file (xml).
    I then followed the instructions to import it into my site – I used the WordPress importer Version 0.6.1 but it did not work – it just said that the files already exists.
    So I installed and tried the WP Re-Importer Version 1.1 but it still says that the posts already exists.

    Please could someone help me with this, I really don’t understand what to do and the tools that are meant to help do not work. Thank you.



    It looks like you may be able to get this to work if you break up your export into multiple files for your posts (three or four) and import them individually.

    So do this for 4 different date ranges:

    You will want to make sure your blog is empty of any previous imported content.


    Hi jackiedana, thankyou for your reply!

    With the ‘All Content’ option – “This will contain all of your posts, pages, comments, custom fields, terms, navigation menus and custom posts.”

    Unfortunately, as far as i am aware, to do it the way you have suggested above, it will not export everything – I need to export the comments, as few they are. Is this correct?!



    Yes, you will need to export your pages and comments separately if you want them on your new blog. The process, while a little less convenient, shouldn’t take a lot of time.


    I have done as you suggested, but it still hasn’t worked. It has imported some posts but has missed others out. And I am still getting similar messages to which I originally got when I tried to export it as one ‘All Contents’ file saying that the they already exist (it was a brand new WP .org site so there could not have been any posts, etc, already on it)
    This is what I am getting:

    Post “flickr” already exists.
    Post “Welcome to Narnia….” already exists.
    Media “Bedroom View” already exists.
    Media “Walkies Down the WhitwWonderLane” already exists.
    Media “Stepping Into Narnia….” already exists.
    Media “…Hello Narnia. x” already exists.
    Media “Snow coated tree in Narnia” already exists.
    Media “Snowed In” already exists.
    Post “Drawing Dreams….” already exists.
    Media “Working Drawing of Guardian – Dog” already exists.


    I have also now redeleted everything and will try it again.. will repost when done so……. fingers crossed


    No it hasn’t worked again, and this time it didn’t import anything other than 33 tags. I have redeleted them again. Please advise. Thankyou.



    Sorry to hear you’re running into all these problems. I’m looking into this issue for you and should have more assistance to offer shortly.


    Thankyou so much @jackiedana, it really is appreciated! I look forward to hearing from you.



    It looks like there’s a few things going on.

    First, the fact that your images have no titles is likely the cause of the ‘media “” already exists’ errors, so you should go through your media library and title all your images.

    Second, if you try to redo an import into a site that already has some content from a previous import, you will again run into duplication errors. The site needs to be empty with nothing in posts, pages, or media, including the trash.

    Finally, most hosting providers should be set up to accept an import of the size of your site, but since yours is not, you have to break up the import into a bunch of smaller files. A colleague tested it by breaking it into seven files (using the same process I explained earlier, but with even smaller chunks) and it worked for him, so you might try that.

    Sorry for all the hassle. Usually imports are really simple, but for some reason your hosting provider isn’t making this easy. :(


    I tried it again but it still doesn’t work.. just does and says the same. I’m redeleting everything again, though it has done this from the very beginning when it was a brand new site so how anything is meant to already exist I have no idea.

    I have been in contact with my server whom just threw articles at me to read on how to move my site even though I did tell them that I had followed the steps correctly and that it didn’t work, to quote he said “The application is created fine, but contents are missing, we can only provide with steps you can take to move the contents across”, and another article I was given the link for was on how to manually install WordPress – bearing in mind that I really don’t know what I’m doing at all with all this, hence why I purchased hosting, as it had the 1 click app for WP. I also pointed this out to him. I still got nowhere..

    I really wish I knew more about it, as you can imagine.. it is really frustrating!

    I don’t know what to try next, any suggestions would be much appreciated please.


    Also, the original exported xml file of my blog with all of the content is only 1.1 MB



    It looks like you still have many untitled images in your Media library:
    (that’s just a sample)

    Please try adding titles to all of those images and try your export again.


    Hi, I was going to tackle that this morning as you suggested.. Though it would seem that someone from my service provider has answered my prayers and migrated it all across.. fingers crossed as I haven’t finished checking it all. I don’t know how they’ve managed to do it but I am beyond grateful. Thankyou for all of your help jackiedana, it really is much appreciated! ;) !



    Oh that’s good news then! Please keep me posted. :)


    ;) I will do, and thank you again!


    Hi Jackiedana,
    I thought I had sent replied previously, though it isn’t showing.. I blame the weather!?

    The migration done by the person at my server didn’t work properly – loads of posts didn’t transfer, among other things. They tried it again, which seemed to work but some things are still missing, including pages, and tags haven’t stayed with the right posts – even so, I thought I’d try and amend everything as it seems to have been the best transfer yet.

    However, I now cannot upload images, or rather they at first seem to but there’s only an outline for the thumbnails, and the images are blank — would this be part of the same problem do you think.. or yet another. I’ve tried to research it, but some suggested it’s server orientated, others not…?!
    I’d appreciate your thoughts.
    Many thanks!



    Sorry for the delay in responding. When you say you can’t upload images, is this an issue with your new self-hosted site? If so, you will need to contact your new hosting provider for assistance as we have no control over what happens on sites hosted elsewhere.

    If you’re having difficulties using your site on, however, please let me know, and I can look into it further for you.

The topic ‘how do you report a bug on wordpress’ is closed to new replies.