How do you switch 'comments' off for a particular page or post in the Ari theme?

  • Author
    Posts
  • #1064905

    brianat9
    Member

    Hello. I’ve just started a blog using the Ari theme. You say that the ‘comments’ option can be turned off for a particular post or page, but I can’t see how to do this in Ari. Also I can’t see how to include a ‘contact me’ widget that would give a public e-mail address? If comments can’t be turned off in Ari can you reccomend another theme with adjustable background colours that does have this option. Many thanks. Oh, and lastly, so you know whether its possible, in Ari, to change background colour, or light/dark background, for a particular page? I’ll look forward to hearing from you in due course. Brian.
    Blog url: http://animistjottings.wordpress.com/

    The blog I need help with is animistjottings.wordpress.com.

    #1065092

    justjennifer
    Moderator

    Comments off: Regardless of theme, in the Post or Page Editor you should see a module called “Discussion”. It is there you can check or uncheck whether comments are allowed or not on a particular post. The default is to have comments. If you don’t see the Discussion module, click on the “Screen Options” tab in the upper right corner of that screen and enable it by checking the box next to “Discussion”.

    Contact me: Why allow spambots to harvest your email address? You can add a contact form to a text widget, which does not expose your email address. Here’s how: http://en.support.wordpress.com/contact-form/

    Background color: No theme will allow you to change the background color/pattern on just one page. Changes in background are site-wide.

    If you haven’t yet, you may wish to read http://learn.wordpress.com/

    #1065108

    brianat9
    Member

    Many thanks Justjennifer. Bear with me, I’m not internet orientated ( beyond e-mails ) and am finding the WordPress interface counterintuitive, despite “learn wordpress”.

    Ref Comments off: I’ve unchecked ‘allow people to comment on new articles’, but this hasn’t removed the comment boxes on my existing pages? Looking down the ‘discussion’ options its not clear how I can do this.

    Ref Contact form: A great idea, thanks – but it inserts a form with my own e-mail address already included in it. Again, I’m flummoxed. How do I get it to insert a blank form??

    Thanks again

    Brian

    Brian

    #1065110

    To remove the comment box from existing posts (after turning off comments for new posts) you would need to edit each older post that already had comments enabled, and turn the comments off in the ‘Discussion’ box that justjennifer has mentioned above. As for the contact form, only you can see your email in it, everyone else will see their own (if they are logged in to WP) or a blank box to fill in if they are not logged in to WP.

    #1065112

    brianat9
    Member

    Ta! I think WordPress could be a lot clearer, e.g: i didn’t see any warning that you’ll see your own e-mail address but others won’t.

    Many thanks.

    #1065113

    brianat9
    Member

    I’ve tried to edit each page to remove the comment box. This doesn’t appear to work either? ( with the page/post open for editing, I’ve unchecked ‘allow people to comment on new articles’ in the discussion menu, and clicked the button to change the setting ). Perhaps, again, it leaves the comment box visible to me, but not to other people ( without telling me )? Or perhaps its visible but dis-abled?

    Aaaaagh!

    #1065114

    shakingmats
    Member

    I couldn’t actually see any posts on your blog, just a contact form.

    #1065115

    justjennifer
    Moderator

    with the page/post open for editing, I’ve unchecked ‘allow people to comment on new articles’ in the discussion menu, and clicked the button to change the setting

    btaylor679 – did you remember to click the Update Page or Update Post button as well? You’ll need to do so in order to save any changes you’ve made.

    #1065118

    brianat9
    Member

    Yes, I think so. When you go to the ‘discussion’ menu, you lose soght of the page being edited, – so I went ‘backwards’ to return to that page, then clicked the ‘Update post or page’ button, but this hasn’t removed the comments box.

    #1065119

    justjennifer
    Moderator

    You should just scroll up and hit the “Update” button.

    If you hit the “back” button you end up undoing what you were trying to do. :)

    #1065120

    brianat9
    Member

    That’s not possible. In the page I want to edit, I click ‘edit’. This takes me to the edit page/post, with ‘settings/discussion’ menu option in left column. I unclick nearly everything in the ‘discussion’ menu, but the page only scrolls up and down the discussion menu! I can see no other way out of that page than backwards? aaaaagh.

The topic ‘How do you switch 'comments' off for a particular page or post in the Ari theme?’ is closed to new replies.