Need help? Check out our Support site, then

how to add tags in published post

  1. I'm a new blogger and am finding WP quite hard work. I have looked at the FAQs, Support, etc but it rarely answers my question or actually works in practice. Here's one thing I don't understand - how do I add tags to a posting I have already published. When I click on add tag nothing seems to happen and when I view the edited posting the tag isn't there. Have tried lots of times and it never works, very frustrating... (And why does the box above this say the topic is not a support question/resolved/unresolved. Of course it's a support question and of course it's unresolved before I have posted it!!).

    Many thanks,


    The blog I need help with is

  2. You go and edit the post you have already posted. Then you add the tags you want: you type them into the "tags" box manually, and then press ADD. Then you save the article. The tags should appear under the text by now.

    This always works for me. You can add or delete tags in this way if you need.

    And when you feel that your problem has been resolved you mark your quastion as "resolved". :-)

  3. That's exactly what I have done, lots of times. But when I click on ADD, nothing happens (apart from a little hand appearing). Could it be a glitch in Mac OS 10.3.9? Any Mac experts out there? I can add tags to this question no problem, btw...

  4. panaghiotisadam

    Try typing a comma after the tag. Or try: Posts > Edit > hover under title > Quick Edit > type tag(s) > click Update Post.

  5. ibisbill
    I'm on a Mac, as well. 10.5 That should not be the problem.

  6. @ibisbill, Are you using Safari 2.x.x, or are you using Firefox or another browser? Safari 2.x.x works better than it used to, but it is not anywhere near completely compliant with wordpress (or the other way around). Safari 3.x.x (10.4.11 and later) works like a dream though.

    If you are on Safari 2.x.x, you will need to either upgrade your mac to 10.4.x or 10.5.x so that you can have the latest version of Safari, or download and install Firefox.

  7. I use Firefox I also have Safari 1.1 which I never use these days but I tried to update tags with it just now and it doesn't work, just like FF... As mentioned I have OS 10.3.9 Panther which is pretty old now and that seems to be the nub of the problem. But WP doesn't mention this anywhere as far as I can see.


  8. Now all of a sudden I am able to add tags to published posts. How strange. There is an awful lot about WP I don't understand...

  9. I take that back. The tags didn't stick. This seems to be a Mac 10.3 thing, will see what happens on my son's new MacBook (10.5, I think).

  10. No problem on my son's MacBook except that you can only add one tag at a time. Same on mine in fact, but tags often don't stick for some reason and it's very slow. I suppose the moral is think of all possible tags before you publish...

  11. I just added tags to a one year old post on my test blog running 10.5.6 and Safari 3.2.1 and then opened the same post in Firefox 3.0.10 and added more to it successfully so I'm not sure what is going on at your end with your son's macbook.

  12. Try the Cookie Dance: log out, clear browser cache and cookies, restart computer. Sometimes that fixes these odd problems.

  13. I danced the Cookie Dance and that seems to have worked, thanks.

    But more problems since - I just drafted a post and lost half of it, I have no idea how, very annoying. And when I went back to it (or maybe just before I lost it) part of it went mysteriously into italics, again no idea how. But strangely I can't change the italics back into plain font, when I highlight the italics and press the i (italics) icon nothing happens. But if I turn other bits into italics that works fine (and I can turn off the italics for that section). Can you help please. As I say I am finding WP hard work and WP is slow...


Topic Closed

This topic has been closed to new replies.

About this Topic