How to disable the "scroll popup" at page bottom?

  • Author
    Posts
  • #932155

    Since recently, when scrolling a page at my blog, un ugly semi-transparent popup will appear at the bottom of the screen. It has links to jump back to the top of the page, to WordPress.com, and to the page of my theme (K2-lite). It has no apparent option to close this popup.
    I really don’t want my blog pestering visitors by popping up this nuisance, so I searched all over my Dashboard for an option to disable this new feature. Couldn’t find it.
    So my question is: how do I disable this “scroll popup” at the page bottom?
    If someone here knows and will tell me, I would be really grateful!
    Thanks – Henkl

    The blog I need help with is stayontop.org.

    #932270

    justpi
    Member
    #932273

    @justpi: thanks for trying to help! Unfortunately, this is not the answer to my question. My problem is not about infinite scrolling. That may seem related, but it’s something different.
    My problem is about an unasked-for little semi-transparent popup window, that will pop up near the bottom of the browser screen, every time a user happens to be scrolling down in a WP page. What’s even more irritating is that this popup remains in place, covering part of the screen, even after the user has stopped scrolling.
    Ideas how to disable this, anyone? Please?
    Thanks!

    #932279

    justpi
    Member

    Your problem is infinite scrolling, because the stupid popup is part of that feature. When there’s no I.S., you get footer credits (as you can see at the bottom of your static pages); when I.S. is on, there’s no footer, so the footer credits are replaced by that irritating thing. The thing can be removed via CSS editing, but WP doesn’t allow removing the credits; so you can either follow my suggestion A and turn I.S. to the “Load More Posts” version, or follow my suggestion D and eliminate I.S. altogether.

    #932288

    @justpi: thanks for your patience with me! Sorry I didn’t understand that the two things are related, apparently.
    I’ll try to follow your suggestions (luckily I’ve got a paid WP subscription that should allow changing CSS) and see if I can sort this out.
    If I manage to kill the popup, I’ll mark this thread as “resolved”… credits to you.
    Thanks again!

    #932319

    @justpi: your suggestion of adding an empty footer widget did work, but only partly. The result being that the popup now has been replaced by an in-page button. At least this is less annoying.
    Of course now I want to also disable this infinite scrolling thing completely. For the button still has the effect of adding more content at the bottom of the open browser page, instead of offering “next” and “previous” links to go to a new page.
    I hadn’t even noticed yet my “next” and “previous” links were gone… But now I see this, this is really bad. Don’t the WP people understand that when you have a lot of long posts with large images, some embedded things etc., this endlessly-adding-more method is not only a waste of memory, but will also cause users to lose their orientation?
    Anyway, thanks for your help, justpi.

    #932320

    timethief
    Member

    juspi and all of us Volunteers answering questions here are fully aware of the fact that using the workaround (widget) to disable infinite scroll will result in a “Load more posts” link. The only way to remove the “Load more posts” is with CSS editing.

    #932321

    Thank you all for your help. I’ve now marked this thread as “resolved” and posted a new one in the CSS section, in the hope someone can get me the code I need for the K2-Lite theme – to restore the original situation with a fixed number of posts per browser page, with Next and Previous links.
    You’ve been really helpful so far!
    Henk

    #932322

    timethief
    Member

    Hi again,
    I see your new CSS thread now. :)

The topic ‘How to disable the "scroll popup" at page bottom?’ is closed to new replies.