Need help? Check out our Support site, then


How to display last post first

  1. No matter what I do I can not get my most recent post to be displayed on my home page. The title of my most recent post shows up first in the list of Recent Posts, which is good, but the post that is actually displayed on the page is the oldest post. I would love some help with this!

    The blog I need help with is crowsnestcompanion.wordpress.com.

  2. Blogs are essentially a reverse chronological order publishing tool wherein the most recent published post will display on top. There is no upgrade that allows you to change this post order on a free hosted WordPress.com blog.

    Reverse chronological order is designed to serve your visitors as they come to read the most recent posts and they will not be inclined to trawl through hundreds of posts to locate it.

    See here for the option of creating a book-like structure > http://en.support.wordpress.com/write-a-book/ Perhaps that will work for you.

    Or you could use a single sticky post as an index page > http://en.support.wordpress.com/posts/post-visibility/#sticky-posts

    Or you can falsify every date-stamp before publishing.

    Staff have provided this support doc http://en.support.wordpress.com/show-your-posts-in-chronological-order/

    If your posts are not displaying in reverse chronological order with the most recently published post on top here is a checklist of what to do below.

    Are you sure your timezone is set correctly?

    1. Confirm your timezone is correctly set
    The default timezone is UTC time. You can reset your timezone here > Settings > General.

    Select the closest city to you in the same timezone in the drop-down menu you see there and then click "save changes".

    2. Make sure any post that's out of order is not out of order due to sticky post assignment.
    http://en.support.wordpress.com/pages/page-visibility/

    3. Check the date and timestamp
    For editing them see:
    http://en.support.wordpress.com/posts/edit-posts-screen/
    Use the images you see here to help you http://en.support.wordpress.com/posts/schedule-a-post/ edit the datestamp and timestamp if required and then click update.

  3. Thank you for your many suggestions -- I have confirmed my time zone is correct and the date and timestamps are correct. Please visit http://www.crowsnestcompanion.ca, click on the Blog icon, and tell me which post is displayed on the page, rather than which post is listed first under Recent Posts. No matter what computer I use, what browser I use, or how many times I clear my cache, each time I visit my Blog, the oldest post is always the one displayed. Please note I did set the latest post as a sticky post but it still doesn't display on the page. What am I doing wrong?

  4. The problem seems to be because the blog icon is hyperlinked to go to https://crowsnestcompanion.wordpress.com/2015/07/11/are-you-abusing-your-aging-parent/ instead of https://crowsnestcompanion.wordpress.com.

  5. Oh my gawsh! What an oversight on my part -- sheesh! Thanks so much Pegodaaj.

  6. You bet. :)

Topic Closed

This topic has been closed to new replies.

About this Topic