How to limit the number of posts on home page

  • Author
    Posts
  • #868616

    zimonawhim
    Member

    My blog loads every single post I’ve made since I started it in February. How do I change the number of posts it shows on the home page? I looked all through the settings and can’t seem to find it. Thank you for your help!

    The blog I need help with is zimonawhim.com.

    #868716

    zimonawhim
    Member

    Found out how they changed to the infinite scrolling and I added a widget in the footer as suggested in a previous question…Fixed.

    #868739

    manperson1
    Member

    Hi, can you say which widget helped you? just noticed this infinite scroll thing and I REALLY want to get rid of it!!

    #868741

    zimonawhim
    Member

    Good morning…I grabbed the one that says “Text” (Arbitrary text & HTML) and put it into Footer Area One. I didn’t put any text in there, just left it blank. When I first checked it to see if it worked, there was a box that said “Load more posts” and then the next time I looked that was gone and it just says “Older” now. After you do this with the widget and you go to your Reading Settings, you can now uncheck “Scroll Infinitely”. That infinite scroll is annoying, isn’t it? Wonder why they changed it and who would want that? Good luck.

    #868779

    timethief
    Member

    @fuzius
    Staff have introduced “infinite scroll” to some themes and will be implementing it on all themes that have a suitable structure for infinite scroll. This is a site wide change.
    https://en.forums.wordpress.com/topic/to-infinity?replies=137 If you have a theme with footer widgets you can use a workaround like zimonawhim describes to regain control over how many posts are displayed on the front page of your blog. However, you are using ChaoticSoul and it does not have footer widgets so see 3. (a), (b) and (c) in the workaround post I linked to above.

The topic ‘How to limit the number of posts on home page’ is closed to new replies.