How to remove strikethrough?

  • Author
  • #564099

    I accidentally clicked on strikethrough, and now all the text in my most recent post (not published yet) is stricken. Pressing the button again doesn’t change it, which is really weird. I’ve looked in the code section and can’t find the relevant code at all.

    Stupidly, I hadn’t saved the draft for a while, and it’s taken me over an hour to insert some photos within the text, or I’d simple trash it and start it again.

    Please help!

    The blog I need help with is


    Is it the one called del? Why would strikethrough be <del>? I thought it might have changed from the old <s> or <strikethrough>, but is it really del? And it has a date and time next to it for some reason.


    Select all the stricken text in the editor and then click the strikethough button again and it will remove the strikethrough.


    Please, anybody? Deleting the <del> codes hasn’t worked.

    I can’t even save the post now, because the save draft button has vanished – only publish is there. So if my computer crashes, as it often does, then the entire thing will be lost. I guess I’ll have to post it with all the writing stricken through.


    Switch to the html tab, copy everything that is there in the window and paste it into a plain text file. Delete everything that is in the HTML window. Log out of wordpress, clear your browser cache and cookies, restart your browser and then log back in and open that post in the editor.

    Switch to the visual editor, click on the “paste as plain text” button on the lower tool bar in the editor, paste the stuff you previously copied out and into the text file into the little window that comes up. Click “insert.” Now you are or should be back to square one with absolutely no formatting on your text.


    Thank you. Do you know if that will remove all the photos?

    I’ve discovered that it is ‘del,’ which makes no sense – seriously who ever changed it from strikethrough to del? – but there are dozens of them, so your method might still be quicker. Also, some of the writing is coming up tiny for a reason I can’t make out so getting rid of the formatting would help that too.

    If you select the text again and press the strikethrough button again, nothing happens.


    As far as I can remember, it has always be del here, never strike. Both look the same in a browser, only the tags used are different and of course they were meant for different purposes.

    I just tested strikethrough in one of my test blogs, and if I highlight a word in the visual editor and click the button, it does the line through the text. If I again click the button it takes the line off.

    The “paste as plain text” should not strip out the code for the images. There is also the “strip formatting” button on the lower tool bar in the visual editor you can try if you wish. Highlight everything in the post, click the strip formatting button and it should take out any HTML formatting but leave the images and any links.



    Another option is to highlight the text then click the eraser button which is the clear all formatting option… Please note all text formatting will be removed but your images should still be there after clearing out the formatting… The button I am speaking of is #7 in this screen shot

    Support document →



    I just tried again, and I’m definitely not imagining it: if I highlight the text that’s got strikethrough, and press the strikethrough button, it stays as strikethrough. What it does is add yet another strikethrough code, hence there being so many in my post.

    I saw the strip formatting button mentioned elsewhere, but I’ve only just found it – I didn’t know the ‘show kitchen sink’ button displayed extra characters (it’s not exactly an intuitive name). But it only gets rid of the bold type, not the strikethrough – that’s still there.

    I’ve just published with the strikethrough. It doesn’t really matter – nobody ever reads it anyway, so it’s more of a personal diary plus proof that I have actually visited each museum towards my 100 target.

    Thanks for the help guys.


    Aargh! The ‘remove formatting’ button also removes the formatting from the photos’ captions, changes the photos’ size and repositions them. It’ll take ages to put them back. The page looks absolutely terrible, and all because I clicked the strikethrough button.


    Did you keep the copy I suggested pasting into the text file?


    The other thing, if you catch errors like this right after they happen, is there is an “undo” button on the bottom tool bar. Row 2, button #11


    Yup, I’ve kept a copy, but for some reason the strikethrough is permanent. Absolutely nothing I can do will get rid of it, in either Word or Editplus. I thought checking and then unchecking strikethrough in Word might do it, but it simply stays. I’ve had to type up the entire thing again.

    And the pictures and captions don’t copy back into the post, of course. They have to be done again and they take an extremely long time.

    I kinda wish someone could sit next to me, watch me highlight text and press strikethrough again, and see that it doesn’t remove the strikethrough, because otherwise I know you guys aren’t going to believe me.


    And undo didn’t work either. I am cursed. :(



    Have you tried via the HTML view with the editor and manually deleted the HTML tag looks like the following below



    Yes – the problem is there were so very many of them because I kept trying to highlight the text and click strikethrough again to remove it. every time I thought I’d got them all, it turned out I hadn’t.

    Never mind. I’ve just done the whole thing fresh from the start. Thanks for all your suggestions.


    @100, use the contact form on the blog linked to my username and when I reply, send me a copy of the text file and I will clean it up for you.

The topic ‘How to remove strikethrough?’ is closed to new replies.