How to turn off Comment and Reblog options in photo gallery

  • Author
    Posts
  • #1795979

    cathyscholl
    Member

    Hi,
    I’m starting a new tiled mosaic gallery page
    http://cathyscholl.com/galleries/powwow/
    and when I click on individual photos on the page and scroll thru them with arrows, COMMENT and REBLOG is turned on for the individual photos even though I have it turned off for the entire page.
    Example: http://cathyscholl.com/galleries/powwow/#jp-carousel-92
    I’ve been trying to edit each individual image via Media Library but I’m not finding a way to turn off Comments/Reblog. Please help. Thanks!

    The blog I need help with is cathyscholl.com.

    #1796094

    justjennifer
    Moderator

    Hi Cathy,

    The quickest way to turn off commenting in the carousel or attachment pages is to turn off commenting for your entire site in Settings>Discussion and then enable commenting per post/page. You can enable it in the Discussion module for each post/page. This will work for future posts, but may not work for posts you’ve already published.

    For already published images, you can disable the image comment box by editing each image from the Media Library. Open the image for editing, head down to the Discussion Module and uncheck the appropriate boxes and then update your Media. Unfortunately, you will have to edit each picture individually, as there is no “bulk edit” feature for Media like there is for Posts/Pages (other than to delete them).

    To the best of my knowledge, reblogging only works on Posts. Have you turned off the Reblog button on your site? If not, you can do that under Dashboard>Settings>Sharing. Once you disable the reblog button, it seems that even if the button appears, it doesn’t actually activate a reblog if the button is clicked. I’ve tested this in general on posts, but haven’t yet tried reblogging only an image from the carousel. If you’d permit me to test this, I’d be happy to do so. Just let me know. :)

    #1796103

    cathyscholl
    Member

    Hi justjennifer!

    Thanks for your reply. I do have commenting turned off for the entire site and you are right it does work for new images I add but not for older ones. In the Media Library I can’t find a way to turn off comments. I open the individual photo and there is no dialog about comments. If I go to the screen options and check the comments box to show on screen there is a box that says “add comment” and under that it says “no comments yet” and that’s all…nowhere to disable comments.

    I’d appreciate it if you could test the reblog button. I have checked “don’t show the reblog button” Maybe this also only works for newly loaded photos…I will try adding one and see what happens.

    My problem is that I am trying to use a blog page as a photo portfolio and want it to look like a website…so even if the reblog doesn’t work it still looks unprofessional to have it on a “website” gallery :(

    thanks for your help!

    #1796105

    cathyscholl
    Member

    p.s. I may have to start a new topic for this but I also want to find out how to turn off “view full size” with each individual photo.

    #1796115

    justjennifer
    Moderator

    Hi again,

    It’s not the Comments Module, but the Discussion Module. Here’s a screenshot that shows the Discussion module in an image’s Edit screen from the Media Library. If you don’t see that Module on that screen, click again on the Screen Options tab to enable it.

    It’s a bit late here for testing now, but if I don’t get to it tonight, I will be happy to do so tomorrow.

    As far as hiding the link to the full size image, as I recall you have the Custom Design upgrade. Correct? If so, you might inquire in the CSS forum whether you can disable the display of the view full size link in the Carousel and attachment pages.

    #1796117

    cathyscholl
    Member

    Hi,

    Ohhh the Discussion module in the Media Library! Got it!
    Comments have been removed, thanks.

    Now all that’s left to remove are Reblog and View Full Size.
    I do not have the custom design upgrade. Can I remove the link to the full size image without the upgrade? I think I will post this as a separate topic since it’s not covered in my original question.
    Thanks!

    #1796132

    justjennifer
    Moderator

    I have checked “don’t show the reblog button”

    The Reblog button still appears on your blog posts (and hopefully you got the notice of the reblog I just made), so please look again in Dashboard>Settings>Sharing>WordPress.com Reblog button> and make double certain that “Don’t show the Reblog button on Posts” is checked and then make sure to save your changes.

    Once you change that setting, it will take effect on your entire site, regardless of when your posts were published. The Reblog button should disappear both on your blog posts and from the Admin bar. Then I’ll test again.

    #1796133

    cathyscholl
    Member

    ok I will check again and will let you know…

    #1796134

    cathyscholl
    Member

    yep…”Don’t show reblog” button had been checked previously and I saved it again…but Reblog still shows on individual photos in a gallery when they are opened.

    #1796135

    cathyscholl
    Member

    justjennifer I just noticed that you reblogged a blog post from my blog. I have NOT turned off reblog on the blog…what I am trying to turn off is the reblogging feature on my website (which is also a wordpress blog):
    http://cathyscholl.com/galleries/powwow/#jp-carousel-92

    If you or someone else could please check…maybe reblogging will not work on the website…that’s what I am wanting to check since that is where I turned it off. Thank you.

    #1796137

    justjennifer
    Moderator

    Cathy, Here’s the thing. Reblogging currently can only take place on blog posts. Go to any of your site’s Pages and there’s no Reblog button there. Open any of your images in a tiled Gallery by right clicking and opening it in a new browser tab so it bypasses the Carousel and you’ll see there is no Reblog button on that image attachment page, like this one. This is why I don’t believe that you can currently reblog from the Carousel, regardless that the Reblog link appears there. So far I have been unsuccessful in reblogging an image from your Carousel although I was able to do so from your blog post.

    I hope that makes it clearer.

The topic ‘How to turn off Comment and Reblog options in photo gallery’ is closed to new replies.