HTML Editor changing code

  • Author
    Posts
  • #316094

    Is anyone else seeing problems with the HTML editor? I can’t insert a vodpod video because the HTML editor keeps changing the & character to & like the visual editor does.

    #316208

    Sorry, changes & to &

    #316212

    vivianpaige
    Member

    What code are you trying to post?

    #316215

    [vodpod id=Groupvideo.1947169&w=425&h=350&fv=]

    But the editor changes it to [vodpod id=Groupvideo.1947169&w=425&h=350&fv=]

    #316218

    devblog
    Member

    Why don’t you try including the code until you’re ready to publish your post?

    I mean, type your post as normal, put a placeholder for your video, and once you’ve typed everything then switch to the HTML editor and replace the placeholder(s) with the actual code, and without changing back to the Visual Editor publish your post.

    See if that works.

    #316223

    I actually wrote the post in the HTML editor, and posted and tried updating from it. I didn’t switch back to the visual editor at all.

    #316226

    devblog
    Member

    Try this:

    [vodpod id=ExternalVideo.768862&w=425&h=350&fv=]

    it worked for me.

    #316228

    I tried to preview that link and it didn’t work at all.

    #316229

    devblog
    Member

    The way previews work is not good: When you try to preview a published post, you need to save your changes in order to “preview” them, which defeats the purpose of such “feature”.

    Create a new post (draft) and paste the code I gave you. Then you’ll be able to preview it.

    #316238

    Thanks devblog, the player is now showing up, but it still won’t play. May I ask where you found that code?

    #316242

    devblog
    Member

    I used vodpod’s bookmarklet. I went to the video’s page and clicked it, then it posted it on my blog. I copied the code from there.

    #316249

    vivianpaige
    Member

    I thought the shortcut codes were supposed to be entered in the visual editor, not the HTML editor.

    #316250

    I’ve had issues with the shortcodes in the visual editor from time to time, but I find if I put it into the HTML editor the only time I have an issue is if I’ve messed up on the code.

The topic ‘HTML Editor changing code’ is closed to new replies.