Need help? Check out our Support site, then

HTML-fluent? Help.

  1. This isn't a WordPress-specific question, or at least I don't think it is.
    I'm hoping someone who knows HTML well might be willing to take a quick look at my code and figure out why the heck my spacing won't work. I've looked and looked and can't figure it out. At, in the first section of my post before the block quote, the paragraph breaks which exist in the source code, don't show up as paragraph breaks. After the blockquote they work fine. But I can't figure out why. I can't find any errors in the code that might have caused it, and the only piece of code in there I can't identify is the word 'span', but I can't see that it would create the problem.
    Anyone with a spare moment have any advice?

  2. have you tried <br />

  3. I'm lost. Are you trying to add in paragraph breaks? And between what specific lines?

  4. Yup, I'm trying to add in paragraph breaks, and there's one section where for some reason they won't 'take'.

    This (below) is the section currently, and I'll put XXXX in the three places where I can't get it to display paragraph breaks despite trying , <br> or
    in the code (I know this is a petty little thing, but I can't figure out why it won't display with a break, when it shows up in the code).

    [SOURCE: The Huffington Post, AUTHOR: Jay Rosen]XXXX
    [Commentary] On August 4, the Association for Education in Journalism and Mass Communication (AEJMC) passed a resolution, the first major statement against the policies of a president since the Vietnam War.XXXX
    The key passage is: “The membership of the Association for Education in Journalism and Mass Communication urges the Bush administration to abandon its anti-press policies.” The resolution identifies ten troubling practices involving secrecy, propaganda and the control of information. It recognizes that there is always tension between presidents and the press. “This tension is both unavoidable and generally salutary: When each side conducts its duties with honesty and integrity, both hold the power of the other in check.”XXXX
    The ten practises in question:

    I'm reloading, so it can't be a cache issue. What the heck am I doing wrong?

  5. Try doing a couple of them with forced spaces like this:

    <br /> <br /> <br /> <br /> <br /> <br /> <br /> 

    You may have to use the normal text editor instead of the rich text editor if you're using it because I think TinyMCE (the rich text editor) strips out the extra br's.

    Hope this helps,

  6. Nope.
    Tried it, but they still won't display. (When you say 'normal text editor' you mean what I get when I click the HTML button? The 'rich text editor' being the main 'write post' window?)

  7. Someone bump this during the overnight and I'll take a look at in in the morning.

    Sorry for the delay but I've now got three minutes until the library closes.

  8. LMighton - Dr Mike means turn off the Rich Text Editor altogether.

    Use the basic editor to do the br thing and it normally works ok.

    If no-one else does, I'll bump it in your overnight, it's morning for me then. :)

  9. @lmighton
    Many of use do not use the "visual text rich editor" at all. We have turned it off.

    Please try this. Go to dashboard -> users -> your profile (scroll down to Personal Options and uncheck the box "use the visual rich editor when writing" click "update profile."

    Now you are using the normal text editor. Now you can use < /br> and it won't be stripped out.

  10. BUMP. :)

  11. Worked for me using the normal text editor using the four lines of br's up above.

    I was going to suggest blockquotes within blockquotes but it appears that strips that out. That's strange because the normal WPMU code doesn't do it. Example

  12. Thanks you guys!
    Whenever I put
      (even 4 of them), using the visual text rich editor, they didn't display.
    First I did what timethief & cornell suggested, turning off the visual text rich editor. But when as she suggested 'Now you are using the normal text editor. Now you can use < /br> and it won't be stripped out.', damned if it wasn't still stripped out!
    Then I tried again with
      so with the VTRE turned off, and it worked. That'ss the only way it would work. No idea why.
    I'm writing this in in case anyone else deals with this same problem, so they can find a way out too.
    That was frustrating!
    Thanks you 3 for your help.

  13. Curiosity, I wonder if some of my problem was because I have checked off the option to have WordPress check and fix my code? Was that working against me? Do you guys for the most part have that option checked, or unchecked?

  14. Most of us have the rich text editor turned off I believe. The RTE or TinyMCE is known for mucking up html code, stiking in weird fonts and the like. It's probably the most well developed web based editor out there and it's really easy to add into other code.

Topic Closed

This topic has been closed to new replies.

About this Topic