https warning on wordpress page

  • Author
    Posts
  • #895023

    emcurrie
    Member

    I see the following warning on my wordpress page :
    This page has insecure content.
    this is followed by two buttons: dont load (recommended) and load anyway.

    I also have the yellow triangle icon on top of https. The explanation for this states that my connection is encrypted with 256-bit encryption, but that there are insecure items on the page that could allow interception of data. Looking up the information on the google Chrome site I see the following:

    The site uses SSL, but Google Chrome has detected insecure content on the page. Be careful if you’re entering sensitive information on this page. Insecure content can provide a loophole for someone to change the look of the page.

    Can you tell me what I should do here?

    The blog I need help with is emcmemoir.wordpress.com.

    #895300

    woodshedec
    Member

    I just registered a new blog and exported content to it. Upon publishing the site, I got the same message, “The site uses SSL, but Google Chrome has detected insecure content on the page. Be careful if you’re entering sensitive information on this page. Insecure content can provide a loophole for someone to change the look of the page.”

    I am afraid this will drive traffic away. I need help resolving this issue big time.

    #895301

    timethief
    Member

    I have flagged this thread for Staff attention.

    #895302

    emcurrie
    Member

    Thanks for flagging!

    #895303

    timethief
    Member

    You’re welcome.

    #895322

    macmanx
    Staff

    Specifically, which URL are you seeing that on?

    #895325

    emcurrie
    Member

    https://emcmemoir.wordpress.com/ in Chrome. I get
    “This page has insecure content” followed by Dont load and Load anyway buttongs

    #895326

    emcurrie
    Member

    Using Chrome as IE deletes the header image and loses the right column. I’m using Twenty Eleven.

    #895330

    macmanx
    Staff

    Ah, there’s your problem. Try just http://emcmemoir.wordpress.com/

    There’s really no reason to serve the blog content over HTTPS, which is why you’re seeing the errors about the mismatch.

    #895333

    woodshedec
    Member

    Thank you for the response macmanx. I was seeing the issue on my new blog at http://woodshedentertainment.wordpress.com.

    Now, right after I posted my request for assistance, I changed the Primary status of the blog and voilà, problem solved. Actually, I cannot explain it beyond this.

    However, I intend to make it Primary again and would like to be sure the alert does not recur. So please…

    Minchie Israel

    #895334

    macmanx
    Staff

    Can you please elaborate on what you mean by “primary status?”

    #895335

    woodshedec
    Member

    …Primary Blog. I own three blogs.

    #895336

    macmanx
    Staff

    That is rather strange. So, if you switch http://woodshedentertainment.wordpress.com/ back to your primary blog, you see the error?

    If so, are you sure you’re not visiting the https version of the URL?

    #895337

    woodshedec
    Member

    I think you have something there. I did observe this afternoon when I copied the url that it was the http version. When the error occurred, it was the https version. The thing is I did not disable https for this or any of my other blogs on the dashboard.

    #895340

    macmanx
    Staff

    Ok, so you only see the error when going to https://woodshedentertainment.wordpress.com/ right, not http://woodshedentertainment.wordpress.com/ ?

    #895341

    emcurrie
    Member

    Hi macmanx,
    http: did take care of the problem – thanks so much. Now working in Chrome and in Firefox.

    Still having a problem in IE9. http: does not fix that problem. IE9 loses the right column and the header image. I realize that this is a different issue; I’ve entered an issue for this in the forum. Any help appreciated…

    #895343

    woodshedec
    Member

    I can now go on my dashboard in https without a problem. In other words, I am seeing none of the errors I alluded to earlier. I just can’t explain what happened in order to be able to avoid problems in the future. But to answer your question, I only saw the error in https prior. I never did switch to http to see if there was any difference.

    #895344

    woodshedec
    Member

    The Alert is back now. Confusing.

    #895349

    emcurrie
    Member

    Mine is back as well. Opening a new Chrome browser and the https is back, with warning.

    #895352

    emcurrie
    Member

    Nevermind, I used an old bookmark that had the https address in it. Once I removed the bookmark, saved the new bookmark and used that or entered the address without the ‘s’ the page loaded correctly.

    So, Chrome seems to work for me. Firefox as well. I’ll post any other problems I have here.

    I’m having a different problem with IE9 having lost the left column and the header. I realize that’s a different topic but I’ve added the link below. Apologies for any protocol infringement/mixing of issues.

    https://en.forums.wordpress.com/topic/cannot-get-header-image-to-appear-in-ie9?replies=2#post-889151

The topic ‘https warning on wordpress page’ is closed to new replies.