I am unable to insert links into new posts

  • Author
    Posts
  • #428344

    tolmsted
    Member

    Hello – I am unable to insert links in my blog. I attempted to insert a link into posts and also in pages. I highlight the text, hit the link key and a box comes up… but there is nothing in it. I am unable to get rid of the box unless I close down the whole page window. Anyone else having this problem or know how to fix it? Help would be greatly appreciated.

    The blog I need help with is booksexy.wordpress.com.

    #428446

    timethief
    Member

    Please post the complete url for the blog to which you refer starting with http://

    #428447

    tolmsted
    Member
    #428448

    timethief
    Member

    (1) What is your operating system?
    (2) Which browser and version of it are you using?
    (3) Have you tried these troubleshooting techniques? http://en.support.wordpress.com/browser-issues/
    (4) Do you have a alternate browser you can try?
    (5) Have you had a recent update to your anti-virus and/or security programming?

    #428449

    tolmsted
    Member

    1. Windows Vista 32 bit
    2. Firefox
    3. I’m not sure what refreshing it will do?
    4. No
    5. No – I’m using the same I’ve always used.

    #428450

    tolmsted
    Member

    I tried using Internet Explorer and the same problem happened. Could it be that the java script is broken? (That’s what I was told – no idea what it means).

    #428451

    timethief
    Member

    Please force refresh your browser and clear the cache and cookies. Then log in again and try to insert a link into a post.

    #428452

    timethief
    Member

    Are you using AVG anti-virus? The recent update to it has caused similar problems for others.

    #428812

    I am having the same issue…using the visual editor…this was not happening yesterday….IE7, XP OS, Kaspersky anti virus, I went in and put the WP sites in trusted lists…gave them unlimited access to scripts in the trusted preferences…still no good

    this does not happen with the HTML editor…but I hate switching back every time I want to put in a link

    Any suggestions?

    #428813

    raincoaster
    Member

    Yes, do as TT asks and give us a link to your blog, starting with http.

    #428823

    supernoob
    Member

    I am having the same problem too. I am not using AVG, and I tested my posts in Firefox and Internet Explorer. When you post, you have 2 options, Visual and HTML.

    The Visual insert link is grayed out, and the HTML “LINK” button is there and I can use it, but when I publish the post the link is gone. If I edit the post, the html tags and link is there.

    See pic: http://codex.wordpress.org/images/b/b6/write1.png

    What I had to do to get it to work is force it to open a link in a new window. Copy and paste the text below but without the quotes (only the 2nd link works for me).:

    “There are 2 links below


    Google in new window

    #428824

    raincoaster
    Member
    #428832

    tolmsted
    Member

    http://booksexy.wordpress.com/

    We aren’t using AVG. I force refreshed and cleared the cache and cookies. No dice. I’m not even getting as far as Supernoob – the window comes up grayed out, no link button, and the only way I can get rid of it is to leave the entire page.

    #428833

    timethief
    Member

    If you have done those things and not been successful you will have to file a support ticket and Staff, who are on holiday hours will get to you after the New Year. http://en.support.wordpress.com/contact/

    #428834

    @supernoob: In the visual editor, the link button is always greyed out before you select some text for it. You write the word or phrase that you want as your link text, highlight it, then click the link button to add the URL.

    The code for a link is this:
    <a href="URL_HERE">VISIBLE_TEXT_HERE</a>
    If you use the button in the html editor and only paste the URL, you only get the first part of the link: the link isn’t “gone”, there’s just no text for one to click on.

    #428835

    timethief
    Member

    Thanks Panos. In all these years I have never noticed that the link was grayed out in visual mode.

    #428853

    razvab
    Member

    hello. i do have the same problem , for my blog..can anyone help me?

    #428854

    razvab
    Member

    in HTML mode is working if i want to insert a ink, but in visual mode not.
    i usualy use the visual mode ,because i can open the link inserted in a new tab.
    please, help me if you you why the blank “inserting link” window appears.

    #428856

    “i usualy use the visual mode ,because i can open the link inserted in a new tab.”

    That’s no reason for preferring the visual mode; the html for a link that opens in a new window or tab is this:
    <a href="URL_HERE" target="_blank">TEXT_HERE</a>

    #428858

    pisagorr
    Member

    I had exactly the same frustrating problem of seeing only blank pop up window when pressing on insert/edit link button in visual mode. Finally I found the reason and solved it !

    The problem is your firewall or antivirus program that is blocking banners/ads.

    You need to add your blogs url in the “white list” of websites that are allowed to display banners/ads.

    I use Kaspersky and adding *myblogaddress.com* to “Banner Ad Blocker” white list solved the problem.

    Now, I can use visual link pop up.
    I hope this helps you to solve it too : )

The topic ‘I am unable to insert links into new posts’ is closed to new replies.