Need help? Check out our Support site, then

i cannot access my blog's dashboard

  1. for three days now, i am unable to access the dashboard of my blog - my blog is ... it ias accessed as .. i've been getting the 'unable to load webpage/no data received' error on my browser for 3 days. i have tried other computers, other browsers (chrome, safari), other networks, and i tried clearing my cookies/cache...still cant load. my user name is: pixelogist

    i can access my blog from outside, like any other user would..however, lately ive had trouble viewing other blogs as well - for example, when viewing another blog, i get the 'unable to load/no data received' error, and have to sometimes refresh multiple times to view that blog

    but refreshing just doesnt work when im trying to view my pixelogist blog's dashboard
    please help!
    Blog url:

  2. Are you currently using AdBlock?

    If so, would you please report that AdBlock is interfering with our website and try to whitelist us ?

  3. thanks. i am using adblock, on google chrome. however, i disabled it completely, and still was unable to open my dashboard. furthermore, i tried on another computer, and on my mobile phone, and on a different browser without adblock (firefox, safari), and still cannot view. i am also unable to view this forum on my computer/network, and have to ask a friend to reply for me. seems like the entire domain is blocked for me. i am planning to move my blog to a self-hosted version, and now im really stuck. i hope this can be fixed! any more ideas? thanks again

  4. I have forced your admin connection to go over HTTPS.

    Was there any improvement?

  5. thanks macmanx, but it still isnt working

  6. any other ideas?

  7. We made some changes just now. Would you please try again after clearing your browser's cache?

  8. it's still not working. Any suggestions?

  9. We are having some issue with one of our third-party CDNs and certain ISPs, which seems to be causing your trouble.

    We're working with them on a solution, and you might also want to try contacting your ISP about this.

Topic Closed

This topic has been closed to new replies.

About this Topic