Need help? Check out our Support site, then

I cannot publish posts

  1. The publish button does nothing. I can save the draft, I can preview it, but when I click publish nothing happens at all. This is a new wordpress blog, I have used WordPress in the past, so do not undersand what is wrong. Would appreciate help.
    Blog url:

  2. Desperate for help here?! Anybody?!

  3. (1) Are you using the secure https:// login?

    (2) Exactly which browser and version of it are you using. If you aren’t sure click here to find out >

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see >

    (3) Please try

    a. clearing your browser cache and cookies >

    b. using the browser with all extensions or add-ons disabled

    c. updating the browser to the latest stable version (not a buggy BETA browser version)

    d. confirming third party cookies is enabled on the browser

    e. confirming JavaScript is enabled

    f. confirming Flash is updated and if required installing the latest version of Flash

    g. resetting your router and modem and rebooting your computer
    then logging in using the secure https:// log-in

    h. another browser

  4. Thanks for taking the time to reply in such detail. I have tried clearing cookies, cache etc, have tried disabling everything I could think to disable. I will try all the other links you kindly provided shortly.

  5. Ok, so I tried those things, thanks again for taking the time. Unfortunately, no joy. Went and used another computer to log in and nothing is happening on there either. So I suspect it is a problem with WordPress itself, not the computer - anybody know how to actually contact WordPress?

  6. Have decided just to use Weebly. So much easier, clicking and dragging everything into place and published first time. So, thanks anyway.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.