I can't change my header image

  • Author
  • #1399261

    I’m using the Nishita theme and when I click ‘Customize’ to change the header there’s no option for uploading a new header. All it says is no image or choose uploaded (where it shows the previous).
    Would really appreciate any help with this.

    The blog I need help with is theperfectnose.wordpress.com.



    Don’t click “customize”. Go directly to > Appearance > Header

    If you have not purchased the custom design upgrade note that no changes you try out aside from those such as Custom Background, Custom Header, etc. which are stated on the theme description pages in the features column (right hand side) will be visible to visitors.

    You do not need to load the design tools unless you have the Custom Design upgrade. All of these functions can be accessed from your dashboard – without loading the custom design tools – no upgrade required.
    Appearance > Header
    Appearance > Background
    Appearance > Theme Options (applicable only to some themes)
    Settings > Reading (set a static front page)
    Site Title and Tagline > Settings > General

    If you are using the preview mode for the Custom Design upgrade some of the settings in that mode will save but they won’t show up on the front end unless you purchase the upgrade.

    To go back to the free options, go to Appearance → Themes → Customize → Colors and click the “exit the preview” link in yellow at the top of the panel on the right.


    Thanks so much-that worked beautifully. I used the ‘customize’ feature to change the header in past versions of WP and hadn’t realized it no longer worked that way =P


    Just to clarify, the theme customizer should give you the option to change the header, but it might depend on the theme.


    Thanks Andrew. That used to be an option on Nishita, but appears to no longer be the case. I should just switch to another theme but haven’t come across a better minimalist, wide format (for photos) one yet.



    In some cases ie. on some themes bloggers have been inconvenienced because Theme Options that were available from the Dashboard are now available only through the theme customizer. (Example: social networking icons in Adelle.) It maybe that your situation is an indication that headers will also be unavailable except through the customizer. I’ll tag this thread fora Themes Staff response. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

    1. If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    2. If you are using an IE browser in compatibility mode please disable that mode. http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    3. If you are running one of the browsers and versions listed at http://browsehappy.com/
    (a) Make sure that you have both third-party cookies enabled and JavaScript enabled

    (c) Disable all browser extensions or add-ons temporarily.

    (d) Try enabling HTTPS: http://en.support.wordpress.com/https/

    Add both *.wordpress.com and *.wp.com to your list of trusted sites under the Security tab. Make sure to uncheck the box for “Require server verification (https:) for all sites in this zone.” http://en.support.wordpress.com/https/#frequently-asked-questions



    theperfectnose – glad you were able to get your header uploaded.

    timethief – the Appearance > Customize section is the new place to manage the appearance of a blog. Functions from other areas, like Theme Options and Custom Headers, are being moved there over time. Thanks for pointing out this issue! We’ll take a look at the header section to see what we can do in the short term to help make the transition smoother.

The topic ‘I can't change my header image’ is closed to new replies.