Need help? Check out our Support site, then


I can't change the text colour in my links

  1. britishbookworm2014
    Member

    Hi
    As part of the "house style" in my blog, I have always changed the colour of hyperlinked text to orange. Since last week, I have been unable to do that - the hyperlink text, just shows as a highlighted block but the text colour remains the same.

    I use chrome, but I clear cookies etc everytime I close down the browser.

    I can't even get it to change if I manually enter the colour instruction in the html code.

    The blog I need help with is britishbookwormblog.com.

  2. Howdy britishbookworm2014!
    Having a look at your website, the links have a Green color now, all the hyperlinks turn Green on Mouse Hover, you can use this information to be able to manage your Custom Colors
    https://en.support.wordpress.com/custom-design/custom-colors/

    Are you looking for specific help, if you already have the Custom Design features enabled, you can paste the code in the Custom CSS and see if it helps you

    .featured-content a:hover {
          color: #2ea2cc;
    }

    You can manage the color of using the hexa decimal https://www.w3schools.com/colors/colors_picker.asp

    Also, if you point out specifically what would you like to change the colors of, we can help you further.

  3. britishbookworm2014
    Member

    Hi. Thanks for your message. Green is the default for the theme. But I always change the hyperlink text to orange and this stopped working last weekend. It simply will jot allow me to change hyperlinked text colours.

    If you look at any of my posts from early june and before you will see that linked text is all orange. This is picked from the standard colours...

  4. Hi again!
    If you are already on the Premium or Business Plan
    Did you try using the Custom Colors options and the code I posted above? Does it help?
    Let me know how it goes.

  5. britishbookworm2014
    Member

    Hi!

    I'm not on the premium plan. I'm on the free plan I'm afraid.

    As i say, this is something that has only stopped working in the last week or so....

  6. Hi Again!
    Not completely sure of the behaviour if something is not working correctly, can you specify details, how would you change the color, can you walk me through the process, and let us know.

  7. britishbookworm2014
    Member

    Of course!

    So normally I would add the link to the text. Then highlight the text that I want to change the colour for. I would then select the "text colour" in the toolbar and select the colour I want to change it to. That would normally change the text to that colour.

    However, even though I do this now (and the html shows that span style colour has changed) the text colour does not change.

    This is only happening with text with a hyperlink behind it. Plain text changes colour just fine.

    Does that help?

  8. Hi again!
    Thank you for the details further, I will tag the staff to check if it's a theme feature or if anything changed lately.
    Please be patient with them, someone will get in touch soon!
    How to get a Moderator to reply https://en.support.wordpress.com/getting-help-in-the-forums/#how-do-i-get-a-moderatorstaff-reply-for-my-question

  9. Hi @britishbookworm2014, do you have an example of a previous post where this worked, or did all previous color-changed links also go back to the default? I'm not sure how you were changing link color before.

  10. Also - I can see when your theme was last modified. When did this problem start?

  11. britishbookworm2014
    Member

    Hi. Please see previous posts which answer pretty much all your questions.

    If you check any of my posts from say 5th june and before you can see the orange text.

    This has been like this for just over a week

  12. britishbookworm2014
    Member

    So normally I would add the link to the text. Then highlight the text that I want to change the colour for. I would then select the "text colour" in the toolbar and select the colour I want to change it to. That would normally change the text to that colour.

    However, even though I do this now (and the html shows that span style colour has changed) the text colour does not change.

    This is only happening with text with a hyperlink behind it. Plain text changes colour just fine.

    This link takes you to the last post where this worked: https://britishbookwormblog.com/2017/06/09/new-release-review-shadow-bridge-sword-awakenings-4-by-j-c-andrijeski-jcandrijeski/

    Thanks

  13. Ah, sorry, I'd skimmed for a link and missed the June 5 detail earlier; I was looking at titles on the blog page and those are all green on hover.

    I did notice this though:
    https://britishbookwormblog.com/2017/06/16/blitz-giveaway-corruption-of-the-heart-by-jessca-manson-authorjesmanson-xpressotours/

    That's from the 16th. Do you not see orange links there?

  14. britishbookworm2014
    Member

    Yes, but that post was created before it stopped working.

  15. @britishbookworm2014 will you send a link to a post that does not work?

  16. britishbookworm2014
    Member

  17. Thanks @britishbookworm2014, and are you using wordpress.com/post or wp-admin for posting, or some other app? I know there were some fairy recent changes to the way wp-admin's editor handles links, so I'm wondering if that's your trouble.

    Also, I did notice the difference between the HTML on the links that do change colors and the ones that don't:

    This won't work: <span style="color: #99cc00;"><a href="#">Link</a> </span>

    But this will work: <a href="#"><span style="color: #ff9900;">Link</span></a>

    And this will work: <a href="#" style="color: #ff9900;">Link</a>

    Also, you might be happier with a theme that has orange link options built in. Or, like @pavanraheja mentioned, you could use CSS to have control over link colors (and more) for the whole site without having to edit the HTML or manually change link colors each time.

  18. britishbookworm2014
    Member

    Thank you for your reply. I use the wp-admin to create new posts and, as I am on the free version, I dont believe I can apply css even if I knew how to.

    I also dont really want to change the theme. Ive spent a very long time getting it how I want to. I don't understand why WP felt the need to change this.

  19. @britishbookworm2014 I know WordPress.org changed the way wp-admin handles links: https://wordpress.org/news/2017/06/evans/

    But in my tests I can still change the link color: I just changed the text color first, then inserted the link.

  20. britishbookworm2014
    Member

    Thanks but I havent been able to do that because I've tried that too.

    However if you tell me how you have done it I will give it a go myself

  21. I typed the text, highlighted it, changed its color, then added a link while it was still highlighted. Here are some screenshots if they help: https://cloudup.com/cWbG14kPW-K

  22. britishbookworm2014
    Member

    I'll give that a try on my next post. Thanks

  23. You bet. Good luck :)

  24. britishbookworm2014
    Member

    Hi. I tried that - no joy. When i click the link on the toolbar to add the link, it doesnt give the cut down link edit box as shown in your images, but rather the full one.

    Can I clarify again that I am on the free, not the premium version.

  25. Free or Premium shouldn't make any difference.

    Hi. I tried that - no joy. When I click the link on the toolbar to add the link, it doesn't give the cut down link edit box as shown in your images, but rather the full one.

    Are you sure you're using the wp-admin dashboard? What you describe above is found in the "My Sites" dashboard. You probably have Broswer issues using that.
    Try working in: https://britishbookwormblog.com/wp-admin

  26. Broswer?? Browser!!

  27. britishbookworm2014
    Member

    In fact, the only way I can consistently do this is by cumbersome html manipulation, which makes the wordpress site a lot less straightforward to use

  28. britishbookworm2014
    Member

    thank you, and yes, I'm absolutely sure that i am creating posts from the WP-admin via
    https://britishbookwormblog.wordpress.com/wp-admin/index.php, and then clicking on "write post".

    This is how I have always created my posts

  29. If you're clicking on "write" top right you're being sent back to the "My Sites" dashboard where you have Browser issues. If you click on "Posts" "Add new" on the left you stay in the wp-admin dashboard and I'll bet your problems will be solved.

  30. britishbookworm2014
    Member

    at first blush, that certainly seems to have worked! I had no idea that they were different other than being a newer editor!

    Thank you for pointing me in the right direction. I'll just stay old school

    :-)

»

You must log in to post.

About this Topic