Need help? Check out our Support site, then

i dont have permission!?!?

  1. I created a new post and published it. And then i thought maybe i should delete it. And when i go to the "manage" files to delete it, its says i dont have permission to do it! when i tried to delete a blogroll, it says, "You don't have permission to do that" at the bottom of the page. Its my own blog! i am the author of that blog! Why dont i have the permission!

  2. Go into your Dashboard -> Users -> Authors & Users and make sure you're set to Administrator please. That's the first thing I would check.

  3. No. It is another bug. I just created a new blog. The creator is already an Administrator. You can not delete pages/posts from Manage Pages.

    However, you can easily work around it by editing the page (Manage-Pages-Edit-Delete This Page) and deleting it from there. Same applies to posts.

    The irony is - I could not give two hoots about these widgets and secure blogging that broke everything.

  4. I'm actually having the same problems with pages and posts, but it also won't let me delete links or link categories!

    I haven't been able to find a workaround for this problem. I just created my blog and I'm fairly new to this. Any suggestions?

  5. I can't do much more than post and edit posts. I can't delete, and I can't delete links or categories. And I've got some I'd like to delete.

    Is this something that's being worked on? Or something that's broke for ever?

  6. I have tried everything I can think of - and I consider myself to be pretty devious when trying to slve a prolem - however no matter what I have tried always results in the same result "You don't have permission to do that". It simply will nor aloow me to delete anything at all...

  7. Try it again? I've fixed some permissions problems that may have affected your blogs.

  8. well im unable to even see my page that i want to get rid of. it juts shows on the front page, but not in the dash board, this along with new pages not showing is a real bummer.

  9. cgsprite - take a look in - is your page there? I see 9 pages.

  10. Donncha - I have the same problem with my blog as well... Can you try your changes on mine? I can only delete the post after clicking to edit them...Then I can delete the post from the edit page.....

  11. br1ckhouse - you should be able to see the "Delete" link on the manage posts page now.

  12. I am having the same problem as everyone else. I cannot delete posts from Dashboard->Manage->Posts; I get the same "You don't have permission to do that" message.

    I also cannot delete categories from Dashboard->Manage->Categories; again I get "You don't have permission to do that" message.

    I went to Dashboard->Users->Authors&Users and checked to make sure that I was an "Administrator". And I was; I am also the only user.

    Help? Anyone?

  13. guess this prob is here to stay for a few ppl....before you do anythin to ur blog, think it through before updating it or else you gona have a hard time to undo it.

  14. frankluvan - can you send a feedback through the Dashboard? that'll make it easier to debug!

  15. Okay, donncha, I sent "Feedback" as you requested. I copied my forum post and pasted it in as the feeback.

  16. Same problem here; cannot delete links or posts. Only user is Administrator.

  17. I got around the inability to delete links by editing the link to remove the URL and the name of the link (and the description for the ones I had). It doesn't entirely work, as there are now blank spaces on my blogrolls, but the link can no longer be seen or used.

    I assume you could do something similar for some of the other problem areas, eg delete the content of a post or page, and then when things are fixed go back and actually delete them properly?

  18. I still cannot delete things. I have a new blog and want to delete the dummy comment and am unable to do so.

  19. Don't use "delete" link in the Page Management (red backgroung on my computer : oh oh).
    Use "Edit" link instead in the Page Management, then click on "delete this page" : works fine...

  20. I have tried the "Edit" link and then "Delete" and it still gives the message, "You do not have permission." Clearing it out leaves a space on the page under the links.

  21. Try FireFox. Something with IE and AJAX ain't working. Look down at the lower left corner when you try to delete something; you probably have an error icon. Click it once and it will display the line and script that crapped and mine have always had ajax in the script name. I believe they use javascript (powers ajax) to accomplish these tasks and it's not playing nice with IE, at least not IE 6 on Windows 2000. When I switch to FireFox on the same PC, everything magically works again. Not a solution, but it might be the workaround you need.

  22. Yes, something is wrong with AJAX and IE. The recent addition of SSL could be a further complication. I'm looking into it.

    The workaroud for deleting posts is to edit the post and then scroll down and click the Delete button. No AJAX is involved there so there is no problem.

    I'll post an update when we get it working. I'm very sorry for the breakage.

  23. That worked for me.

  24. You can also toggle the visibility of the links - so even though you can't delete them at the moment for some unknown reason, you can make it so that they don't show up on your Blogroll. You do this on the Manage links page, where you can check the boxes next to the ones you don't want, then click on Toggle visibility at the bottom of the page. This has worked for me, and I'm using IE.

  25. I think we finally got it. Login again to get a fresh cookie and kick the tires.

  26. I canĀ“t create new categories. I saw "You don't have permission to do that" msg all the times.

  27. Same as above, I'm still getting that message when I try to create categories. So what's the go with this? Is is being fixed up?

  28. Did you try Ryan's suggesting of logging out, clearing your cookies, and logging back in?

  29. I can't add categories either! And neither can I delete this other category I created long time ago. It says I do not have permission to do so. And yes I did log-out, clear and log back in. Twice.

    What gives?

  30. In order to create categories, do as usual, but instead of creating that shiny button press enter. For some reason it bypasses the error and your category still gets created.

    I dunno if this would work for several of these other problems as well.

Topic Closed

This topic has been closed to new replies.

About this Topic