I need to change the API key

  • Author
    Posts
  • #106586

    saturn2888
    Member

    Somehow there were a lot of screwups as my friend setup the original WP blog I use for my university organization. I setup blog stats but cannot access it. I’m getting rid of my person blog with WP and want to put my API key on the University Org’s one so I have access to the blogstats. I can’t find any info on how to change the API key. Is this possible?

    #106836

    timethief
    Member

    From the FAQs http://faq.wordpress.com/2005/10/19/api-key/
    Where is my WordPress.com API key?
    Every user of WordPress.com gets a unique API key they can use to access a number of services. This key should be as kept as secret as your password — don’t share it with anybody.
    To find your key go to your dashboard and then click on “Profile” (or “My Account”) and you should see a sentence that says “Your WordPress.com API key is:” followed by a string of 12 letters and numbers. There you have it! You can copy and paste that string to any place where it is asked for by a service you want to use.
    If your blog is on WordPress.com then you are automatically protected by Akismet.
    If you have a blog here but you use WordPress somewhere else then use the Akismet plugin to save yourself from spam.
    You must have registered here at wordpress.com to get an API key. Just having a wordpress blog somewhere else does not get you a key.
    You can see your key at http://wordpress.com/profile

    Your best bet is to send a feedback to staff. Volunteers answering forum questions cannot help you.

    #106837

    trent
    Member

    No way to change the API key no. Only way is to signup for another new account.

    Trent

    #106839

    timethief
    Member

    Tx Trent :)

    #106843

    saturn2888
    Member

    I know what my key is. I know probably even what the site’s key is, but either way, I want to change it to mine and not the one on there. I have a site with an API key, and I have one that I’m not using at all. I want to switch them out.

    I’m asking because I’m getting this error when checking my blogstats.

    You are not a member of this blog.

    If you have just installed the Automattic Stats plugin, this error probably appeared because the API key entered in the plugin belongs to a different WordPress.com user account.

    * Have the owner of the API key visit this page and add you to the blog, or
    * Get your API key here, then deactivate and activating the plugin and enter your key to add your account to the access list for this blog.

    #106844

    timethief
    Member

    I don’t believe they can be “switched” without the intervention of staff and a Moderator has just weighed in (see Trent’s post above).

    #106845

    trent
    Member

    I don’t know for sure as I am not Staff, but off the top of my head, I don’t think it matters which one you choose. I know they frown upon (and even delete) users who use their API key on many blogs, but the new stats portion is ‘uncharted’ territory! Best bet is follow TT’s advice and drop a line to the Staff though the feedback button in admin, support tab in these forums or email to support at wordpress dot com!

    Trent

    #106846

    saturn2888
    Member

    Okay, I disabled and re-enabled the plugin. It says this:
    Error from last API Key attempt:

    The owner of that API Key (saturn2888) is not on the access list for this blog. Please ask an administrator to add you.

    #106847

    trent
    Member

    That must be because you are not on the blog as an admininistrator. I think that is a requirement. Whoever the admin is (even if it is you), must add you to the blog so that you can use this key. It must check on the ’email address’ then?

    Trent

    #106848

    timethief
    Member
    #106854

    saturn2888
    Member

    Yeah, my e-mails are different. This is so weird. Mine’s not a WP hosted blog, it’s at it’s own domain name hosted on a separate server. The problem is, I can’t ask WP support for help then.

    #106984

    saturn2888
    Member

    Should I just make another topic entirely?

    Because now it’s not changing the API key, I figured out that, but it’s figuring out how to add myself (the owner of the blog) to the access list.

    “Error from last API Key attempt:

    The owner of that API Key (saturn2888) is not on the access list for this blog. Please ask an administrator to add you.”

    That’s the exact error I get now while I’m logged in as admin.

    Thing is, my friend, who made this whole thing for me last year, says he put it all under my name so why I can’t get in is just so odd.

    #106985

    drmike
    Member

    Gotta admit that I’ve never seen this error in the past and a quick google search doesn’t show any hits. I’d go ahead and use the contact form over at akismet.com and flat out ask them what teh issue is. Please be sure to include a copy of your key.

    #106986

    ryannjenn
    Member

    Just for reference someone just yesterday had a similar problem as well:

    https://en.forums.wordpress.com/topic.php?id=11138&page&replies=9#post-78978

    #107035

    saturn2888
    Member

    Hmm… That’s weird. So at least I’m not the only one. That person didn’t get a fix either did they?

    #107036

    mark
    Staff

    The person using the key must be an admin on the blog here.

    Create an account
    Note the key
    In your blog, deactivate the plugin
    Activate the plugin
    Enter your key

    That should work.

    #107037

    sytycd
    Member

    YES!! I figured out a solution that works for me. I’m not sure why this isn’t documented better.

    I personally don’t think that WordPress.com allows you to change the API key for a blog once it has been entered once. So, saturn2888 is right that the real question is how do you give a different WordPress.com user permission to the stats.

    I kept going to my global dashboard and the form to add permissions to my stats never appeared. I didn’t see it for 2 reasons.

    1. I was looking at the stats for my WordPress.com blog and so there was no form to add permissions for my external blog.
    2. When I switched to my external blog stats page I was too quick and the stats hadn’t loaded yet. So, it didn’t show the form on that page either.

    Once the stats page finally displayed the stats for my external blog, then I was able to see the form that let me grant my other WordPress.com user to see my external blog’s stats.

    One note also is that once I added my second WordPress.com account to see my external blog’s stats it was only added as a subscriber. You have to click a “Promote” button to make that user an administrator that can give other WordPress.com users permission to see the stats.

    That’s how I got around not putting in the right key in the first place. That’s what I get for having 2 WordPress.com accounts. However, I think one of them was created before WordPress.com so I could get the API key. Then, I was lazy and just copied the Akismet API key into the stats program instead of going and getting my other WordPress.com user’s API key.

    #107049

    dangayle
    Member

    We’re getting this error at Geek-vs-Life.com too. Even Joe, the creator of the site and the one with the registered API key gets the error. Everything was working well until the 27th of June, then we get the error.

    I told him to double check the API key at his global dashboard, but he’s not a nerdy enough guy to even want to mess with it to begin with. He set everything up once originally, everything worked great, and now even he can’t get access to the stats.

    Any thoughts?

    #107064

    guardrail
    Member

    same problem, same troubles :-|

    any solutions, plz?

    #107065

    timethief
    Member

The topic ‘I need to change the API key’ is closed to new replies.