I want to get rid of pingbacks

  • Author
    Posts
  • #3029464

    erickuns
    Member

    OK, folks, before bothering you I tried to research this, and nothing I found worked. I disabled “Attempt to notify any blogs linked to from the article” and “Allow link notifications from other blogs (pingbacks and trackbacks) on new articles” in settings.

    So, for example, I have a “support” page, and I link to that at the bottom of a lot of my articles. Now the support page has 40 pingbacks from me at the bottom, which doesn’t look good to me. I would like to remove those.

    Help?!

    The blog I need help with is artofericwayne.com.

    #3029564

    justjennifer
    Moderator

    Hi there, pingbacks are like comments; you should be able to delete the existing pingbacks in your comment dashboard at https://wordpress.com/comments/approved/

    In order to prevent pingbacks from appearing on an already published post or page you’ll need to edit the page and in the panel on the right side, click on the “More Options” link. There under “Discussion” uncheck the box next to “Allow Pingbacks and trackbacks.” However, this also means that if other people link to that page, their pingback won’t appear.
    https://en.support.wordpress.com/comments/pingbacks/

    There’s also instructions in that support guide on how to stop creating self-pings.

    Another way to deal with this without entirely turning off pingbacks is to moderate your comments, if you aren’t already. As I mentioned earlier, pingbacks are treated like comments so if comments/pingbacks are moderated, they’ll appear in the Pending tab and you can delete them there before they appear.

    Also, if you have the Personal, Premium or Business plan upgrade, that makes you eligible for direct assistance by LiveChat or Email. When you are logged in with the username that purchased the upgrade you can post at https://wordpress.com/help/contact Thanks.

    Hope that helps. Let me know if you have any other question about this.

    #3029589

    justjennifer
    Moderator

    Hello again, I see you’ve managed to remove the pingbacks on your Patreon page. :)

    One thing I just remembered and which is mentioned in the support guide to pingbacks is email notifications to your Followers. If you use the relative URL option when creating a link to your Patreon page (in order to avoid creating a self-ping), this can be an issue if that link appears in your email notifications of new posts to Followers. As it says,

    “The links will be invalid when used outside of the blog, like in subscription emails.”

    If your current setting is to send the entire new post to followers by email (or in the Reader) and your follower clicks the link appearing there, they will end up with a 404. One way to get around this is to add the link to the end of your new post and set your Feed settings to send only a summary of your new post and not the full post. (Guide here: https://en.support.wordpress.com/settings/reading-settings/ ) That way readers will need to click through to read the full post on your site where the relative URL is correct.

    Hope that helps. Cheers!

    #3029638

    erickuns
    Member

    Yeah, I just went into my “comments” section, selected “pings”, and deleted them by bulk, until I’d deleted all the recent ones that were annoying me. So, now, it sounds like the links may not work in email notifications unless I allow a pingback or some tricky thing with a “realtative URL option”. Why so complicated?

    How about in the future I just don’t approve those pingbacks? It’s supposed to be, I thought a ping BACK, not part of the link forward.

    #3029813

    justjennifer
    Moderator

    If you want to keep pingbacks but delete them before they appear, then moderating comments is the way you want to go.
    https://en.support.wordpress.com/settings/discussion-settings/

The topic ‘I want to get rid of pingbacks’ is closed to new replies.