Need help? Check out our Support site, then


Illustratr- how to disable comments and hide meta/exif data

  1. I'm using Illustratr and in all the projects i've created, i unclicked "Allow Comments" but I still see the comments feature on all devices (pc, mobile, tablet).

    Is there CSS code to disable the comments?

    Also I read somewhere that in order to hide all the meta/exif data, you need to disable the comments. If that's not true, is there CSS code to hide all the meta and exif data for image files?

    Thanks,
    Katherine

    The blog I need help with is stacypetty.com.

  2. I just realized that on the mobile view, the Titles of images are visible. They are not visible on a computer screen.

    How can I hide Titles of images?

  3. Hi @stacypettystudio,
    There's no way to disable the comments using CSS, but you can definitely hide them using CSS. Here are the CSS codes:
    Hide the leave comment link:

    .entry-meta {
        display: none;
    }

    Hide the comment area:

    #comments {
        display: none;
    }

    Hide the comment area on the image slider:

    .jp-carousel-buttons {
        display: none;
    }
    
    #jp-carousel-comment-form-container {
        display: none !important;
    }

    I just realized that on the mobile view, the Titles of images are visible. They are not visible on a computer screen.

    How can I hide Titles of images?

    Are you sure the titles are visible on the mobile? Because i checked some pages like the Drawing and the Sculpture page, i could not see any titles for the images. The titles are only shown when i click on the images and it opens the carousel.
    Or, i am misinterpreting your question... can you please explain which titles you are exactly referring to?

    Hope this helps :)
    Thanks!

  4. Thanks so much! the comments are hidden...

    For the Titles I just deleted them. Since it autofilled, I thought I couldn't delete them because it was the file name.

    Is there a way to hide the exif camera info? I thought it would be hidden along with the comments section but I still see the camera info.

  5. Thanks so much! the comments are hidden...

    For the Titles I just deleted them. Since it autofilled, I thought I couldn't delete them because it was the file name.

    Is there a way to hide the exif camera info? I thought it would be hidden along with the comments section but I still see the camera info.

  6. Hi, go to Media Settings and you can uncheck Show photo metadata (Exif) in carousel, when available. under Image Gallery Carousel and save changes.

  7. I give up. Could you please tell me exactly where the Media Settings are in the Illustratr theme? I see Media>edit, Account settings, project settings... but no Media Settings...

  8. Let's just take you directly to the page in your wp-admin. Click this link and look at Image Gallery Carousel, and go down three under Metadata. Uncheck that and all should be good to go for you.

  9. There's no link in your message...

  10. Thanks so much.

    Have another issue- The gallery/project that has the images. I've been shuffling things around so that they all fit in the thumbnail grid pattern but when all the images look lined up on the full computer screen, they get messed up on a mobile device. And when they are all lined up on a mobile device, they are messed up on a full computer screen. By "messed up", the spacing is off and it looks like an image is missing here and there. Is there a code to make all the images remain with the same spacing on any device?

  11. PS. specifically, the Sculpture section, no matter where you view it, the smaller the screen, the smaller the images. But for the Drawings, for some reason, if you change the size of the screen or view from another device, the images don't adjust to the screen, they remain the same but shuffle around and it looks like there are images missing in the grid.

  12. Hi there Stacy,

    Richard hat to step out today but he asked me to take a peek at this with you.

    It's possible this might be a bug with the theme's built in CSS that aligns gallery images in a 3 column grid.

    When I tried this CSS, the Drawings area worked just fine.

    Could you add it and let us know if it looks the way you wanted?

    .gallery-columns-3 .gallery-item:nth-of-type(3n - 3) {
        clear: none;
    }
    .gallery-columns-3 .gallery-item:nth-of-type(3n + 1) {
        clear: left;
    }

Topic Closed

This topic has been closed to new replies.

About this Topic