Need help? Check out our Support site, then

I'm not able to access a blog where I am a second administrator.

  1. I share a blog with my sister. We tried to add me as a second administrator, and I did receive the email invitation and followed the instructions. But when I try to access the dashboard, I get an error message that says "The page you requested does not exist, or you do not have have the necessary privileges to access it. You may return to the dashboard of peacelovewaterbeds by clicking here." Also, when my sister is logged in, under 'Users' the account indicates that there are two administrators, but does not list my name. It just shows Administrator (2). She has tried to re-invite me but it says that I'm already an administrator. Please help, I can't get any work done!
    Blog url:

  2. I should also add that I have cleared my cache and cookies, tried changing passwords and signing in/out, asked my sister to do the same on her end. I've also waited a week to see if it would somehow resolve on its own.

    Nothing we are doing is changing the situation. Need help on this soon, this 'glitch' is causing us to be unable to do the work we need to do!

  3. Bump

  4. This thread is flagged for Staff attention. What's required is your patience please. When we create a support ticket by contacting Staff or by flagging a thread for their assistance it’s important to understand they have a backlog. They deal with the support tickets and threads with the earliest dates first. So if we contact them more than once on the same issue or bump threads the date moves forward and it takes longer to get help.

  5. Thank you, I didn't realize anyone had been contacted until you just told me. I will be patient and I really appreciate your help!

  6. You're welcome and please hang in there. :)

  7. Hi there - I'm investigating your issue and will keep you posted. Thanks for your patience.

  8. Hi, I'm sorry about this. You should be all fixed up with the correct role on the site now.

  9. I am having this problem, too. I am the administrator for the blog at I set up a profile for the owner as marty605, and invited him to be an administrator. He accepted the invitation. We can access his profile account. But when we try to use his username and password, it says he isn't an administrator and I need to invite him. But he's already invited and accepted! What else do I need to do?

  10. smejssnacks - I've added the user marty605 to your site manually as an administrator.

    If you need further assistance - or if anyone else has an issue with their site users - please start a new thread rather than adding your own issue here. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic