Need help? Check out our Support site, then

Image layout on static page

  1. I have a static page titled "article clips", and I would like to put pictures of articles that I've written with links to the jpeg. I tried listing them by date, but the formatting is all sorts of screwed up! It won't stay vertical or horizontal, the words and pictures just go everywhere! I'm losing my mind here. I would like to be able to put my work up, but this is maddening!

    The blog I need help with is

  2. Why don't my images align the way I want them to?
    The alignment icons in the WordPress editor are for aligning text; they are not for aligning images. are used to achieve wrapping text around images on either the right or left hand side, or to display an image that's centered without text on either side of it. If the text beside the images does not occupy the same amount of space that the image beside it does then the text wrapping will continue and the images and text that follow will have a staggered appearance.

    • Align-left means position left, with the rest of the content wrapping around the right side of the image.
    • Align-right means position right, with the rest of the content wrapping around the left side of the image.
    • Align-center means position center, with no wrap-around (= the rest of the content below the image).

    So if you want two images to be side by side on the same line start by setting the alignment of both images to left. To prevent the staggered effect what you do is insert the following snippet of code into the HTML editor after each image/text pair:
    <br style="clear:both;" />
    More on WordPress Formatting and Spacing

    If you would prefer thumbnails linked to full sized images in a gallery format. An image gallery will display a set of thumbnail images attached to a particular post or page. When clicked, gallery images are displayed in a full-size carousel view.
    Here's an excellent gallery resource >

  3. first link above replacement link >

  4. Thanks; it seems to be working, but then as soon as I edit it, the "<br style="clear:both;" />" disappears. It goes back to the way it was as soon as I try to add another entry.

  5. I hope you understood that you are to use the code in the HTML editor and not the Viaual editor. Take out those quote marks too:
    <br style="clear:both;" />

  6. Lol, yeah, it was just because I was toggling between the visual and HTML editor. Thanks a lot.

  7. Hi again,
    I'm gald we have resolved this. May I suggest that you bookmark this thread? :)

  8. Absolutely.

  9. Best wishes with your blog. :)

Topic Closed

This topic has been closed to new replies.

About this Topic