image size in gallery does not adjust width anymore?

  • Author
    Posts
  • #256333

    bruderz
    Member

    I just noticed today that individual images from a gallery do not resize to fit the column width anymore. Instead each image is shown in its original size, which now bleeds into the side bar and cuts off half of the image. This was different until just a few days ago. Until now when clicking the thumbnail of a gallery, it showed the image resized to fully fit the width of the column. I am using MistyLook Theme. Here is a link to one of the galleries in my blog that exhibits this problem:

    http://bruderz.wordpress.com/2008/08/07/chautauqua-2008/wimg_8377/

    I’ve tried it in Firefox 2 and IE7, same result.

    Any ideas?

    #256461

    justjennifer
    Moderator

    If you used the Gallery feature to insert those images, they seem to be actually displaying at full size because none of them are “clickable” leading to the full-sized image, which is not how I understood the Gallery feature to work.

    Since we don’t have access to the guts behind the Gallery shortcode, I’d suggest contacting support about this problem.

    #256467

    @justjennifer: You’re right that bruderz must contact Support. Let me just note that bruderz did not describe the problem accurately; the link he’s given is not a post with a gallery – it’s the strange result you get when you click on the fifth thumbnail of this post (which has a gallery alright):
    http://bruderz.wordpress.com/2008/08/07/chautauqua-2008/
    Same thing happens with all the thumbnails of that gallery.

    #256483

    hervej
    Member

    You’re right Bruderz, there’s a resizing problem. I’ve got the same problem than you, and yersterday my photos were resized fine … I was not sure before reading your post (although I was sure I had tested my galleries …) but now, I’m really sure this problem did exist before !

    See my post here (I did not see your post when publishing mine … ) : https://en.forums.wordpress.com/topic/gallery-ordering-and-image-sizing?replies=6#post-238054

    And my problem here : http://notrepetitefamille.wordpress.com/2008/07/28/coupe-de-france-de-joute-a-grigny/img_1124/

    Hope the WP support team will solve this problem ;-)

    #256484

    hervej
    Member

    Oups, i wanted to write “now, I’m really sure this problem did NOT exist before !”. Sorry for this (I cannot modify my post, too bad :-( )

    #256503

    bruderz
    Member

    @justjennifer: yes I am using the gallery feature [gallery], for which we have no way to modify its behavior. I also agree that the gallery feature should be setup so that when viewing a particular image, it is scaled to fit the page, and also is click able, to link to the original sized image. Right now I tell people to use the browser option ‘View Image” to do this kind of thing.

    @hervej: yes, it seems you do experience the exact same problem as I do. I thought maybe its a problem with my theme, but since you have a different one, I guess its not.

    How do I contact support? I thought this is the support forum?

    #256505

    justjennifer
    Moderator
    #256547

    justjennifer
    Moderator

    Just tried this in a test post on my own blog using “The Journalist” theme. No resizing is taking place on the Attachment pages on my theme either, so it’s not the theme, it’s the shortcode.

    I also filed a Support ticket.

    #256566

    tellyworth
    Staff

    I think we know what’s wrong now. We fixed a bug. Turns out many themes depended on that bug. Code goblins are on the case.

    #256567

    justjennifer
    Moderator

    Thank you Tellyworth! There’s also one more thing. Can you please ask them to look at this?
    http://gammagirl.wordpress.com/2007/08/17/image-resize-test/

    #256583

    bruderz
    Member

    sounds great1 Thanks for checking it out so quickly.

    So how does it work? Will each Theme creator/designer have to change their code now?

    #256625

    hervej
    Member

    Great news ! Thanks for the Code goblins, and hope this won’t be too much work for them ;-)

    #256749

    teck07
    Member

    Nice i’m not the only one with this problem
    hope they can fix it soon…

    #256764

    bubel
    Staff

    The fix has been deployed. Give it another try.

    #256766

    meronpan
    Member

    yay, looks like it’s working again

    #256787

    hervej
    Member

    It’s working too on my site. Thanks a lot !

    #256790

    justjennifer
    Moderator

    Fabulous, many thanks!

    The images are now resizing, but you still can’t upload a separate image to another post and insert it into a Post where there is a Gallery. The separate image becomes part of the Gallery rather than remaining a separate image. The method for doing this was first suggested in a forum post by Nick and used to work before this weekend’s changes.

    http://gammagirl.wordpress.com/2007/08/17/image-resize-test/

    #256791

    hanni
    Member

    No probs, sorry about that guys :)

    #256792

    Found a solution to that, justjennifer: Upload the image the normal way, SAVE THE POST, then click “Add an Image” again, click Gallery, delete the newly uploaded image, save again. It gets removed from the gallery BUT NOT from the media library, so you now have it as a separate image in the post.

    #256793

    justjennifer
    Moderator

    @panaghiotisadam Just tried following what you posted and, in my case, deleting it from the Gallery in the Image Uploader also deletes it from the Media Library.

The topic ‘image size in gallery does not adjust width anymore?’ is closed to new replies.