Need help? Check out our Support site, then

Image upload error

  1. Hello,

    For 24 hours I've been getting the same error message when I try to upload images to my blog. I'm using firefox.

    I've emptied the cache, removed the cookie, tried using Safari and nothing works. I've also tried uploading via the media library as well as from directly in the post and I am getting the same error: An "error occurred in the upload. Please try again later."

    I've also noticed that just in the split second before the browser loads the site, I can see a lower case 'g'. I've never noticed this before and have no idea if it's relevant.

    The rest of the site seems to be working fine - I can write the post and preview it, just not upload any picture.

    thanks for your help!

    The blog I need help with is

  2. nicholastrandahl

    I have the exact same error and am seeking a solution as well. Very frustrating. I'm also noticing the lower case 'g's in various places throughout my Reader and Dashboard.

  3. For 24 hours I've been getting the same error message when I try to upload images to my blog. I'm using firefox.

    And exactly what does that error message state? Please post it here.

  4. An "error occurred in the upload. Please try again later."

    Oops! I see it now. Sorry but there's nothing I can do aside from tagging this thread for Staff support and do note that it's a long weekend.

  5. not a long weekend in Australia :), but thanks for letting me know that there's likely to be a delay in any response.

  6. Same here! Basic Images will not upload. Is there a solution?

  7. Hi wendyblume, sorry to hear you're having trouble with this. Does the error only happen when you try to upload images to your blog at or does it also happen with the other blog on your account, too?

    Sometimes errors can occur if the image file is too large or has a filename with special characters (other than letters or numbers). You may also get an error if your internet connection is slow or if the connection to the server is interrupted. You can read more about these issues here: Troubleshooting Images

    If the image is small and has a simple filename, can you start by letting me know what exact steps you take to try to upload the image? Please go to Media > Add New in your dashboard and try these three methods — let me know if any of them works for you:

    1. Drag an image file from your computer's desktop or a folder to the upload page.
    2. Click on the "Select Files" button and select an image from your computer to upload.
    3. Try using the browser uploader instead of the multi-file uploader.

    @nicholastrandahl and @lrlofton, please also take a look at the Troubleshooting Images page and let me know if any of the steps above resolve the issue for you. If it's a connection issue, we will need to troubleshoot the issue for each of you separately.

  8. Could it be possible that its related to the Edgecast CDN and some Telstra customers in Australia? I've heard through the grapevine that there's been quite a lot of disruption over the past few days. Something has been fixed though - I've not changed a thing and now it's all back to working like normal.

  9. If there was a disruption with the Edgecast CDN and Telstra, that could cause the error you received while uploading images. (Any kind of connection issue between your computer and our servers can interrupt image uploads like that.) I'm glad to hear that it's resolved! Please let us know if the issue pops up again and we can look into it further. :)

  10. I am having the same problem and I have trouble shot it and have come up with no solution as of yet. My filenames are simple and the file sizes are small. Ive tried to upload different images and I'm still getting the same error telling me to try again later. It's very frustrating.

  11. @ jaywoodson - Can you let me know the exact steps you are taking to upload the file and when you see the error? If you haven't yet, please also try using the browser uploader instead of the multi-file uploader and let me know if that makes a difference for you.

Topic Closed

This topic has been closed to new replies.

About this Topic