Image upload not working – times out

  • Author
  • #518273

    I am having trouble uploading images from my computer to my blog.

    When I upload using Chrome, I get a message ‘waiting for’. After that, it times out. Sometimes it says ‘uploading 55%’ or some other random number, but it just hangs there and then I get the time out message. I am having the same problem with Safari.

    This started a few days ago, but doesn’t coincide with the installation of any new software, or with a change of settings. I’ve cleared the cache, re-started my network router, re-started my airport, etc., but to no avail. I can upload to a different server using Filezilla, so I don’t think it’s anything to do with data restrictions on the network side.

    The blog I need help with is


    This webpage is not available.

    The webpage at might be temporarily down or it may have moved permanently to a new web address.

    > result of waiting for image upload to timeout on Chrome.


    Also forgot to add that I can insert images from elsewhere on the web – it’s only uploading my own images that is problematic.


    Images have been flakey for the past few days. Staff is out doing staffy things (secret stuff I suspect) but they are monitoring the forums, so I will tag this thread so that they see it and hopefully they will look into it for you.



    The link you are referring to is working fine over here. Are you still experiencing the problem?

    Also take a look at the following support documentation:



    I have been having this problem with uploading images for the past several days, too. And I can’t even seem to insert a link to a web-page into a post. Very weird. Has kept me from posting anything for several days. What’s the point without images and links?



    I am having the same problem:
    one of my authors reported the problem and I am getting the same thing. It says it is crunching, and details are there, but no actual image and on the post, it shows as a broken image link.
    Images are not that big one 43kb one 143kb(plus I have tried lots of smaller files to check..ones that are only 9kb)



    I also cannot insert an image, either from My Computer or a URL. Using FireFox and XP Pro, BTW.


    Thanks for the replies everyone. I’ve tried everything on the support list, and can’t fix the problem. I get to the upload screen, select my image, press upload and then get a ‘waiting for’ message that doesn’t go away until the site times out.



    HEY! Safari works!; I tried IE7 and I get “error on page” while on Firefox and Chrome I get nothing at all.



    Now my problem has gotten worse and when I try to open/edit the draft post where I was trying to insert images last Friday, none of the text appears (it only appears if I hit “preview” so the text was not deleted from the blog, it’s just not showing up for editing purposes). Same for my published posts — none of the text will show up if I try to go into edit mode to make a change. I don’t know what to do. I deleted all cookies and everything like that from Internet Explorer and tried restarting my browser. Nothing. Same thing happening in Firefox. What’s going on?



    To everyone:

    Please try using browser uploader instead of Flash uploader to see if it works, in case you haven’t tried.

    And try restarting the browser in a “safe mode” to make sure your customization (extensions, add-ons, settings) are not causing this.

    This could be caused by your firewall settings or antivirus software. If you have any other location or machine you can test this with, you may be able to narrow down the source of this issue.

    Please post full text of the error message if you’re seeing any.


    Your blog is not on, and we are unable to provide support here. Please visit:

    (Also to everyone: Please make sure you’re seeing [YOURBLOG] URL. Otherwise, the above suggestion applies to your case as well)



    I was able to upload an image using the URL you provided in the beginning of the post (feel free to delete it after checking).
    What happens if you download previously uploaded image and try to re-upload it? Will it still give you the same error?



    Maybe you have done this and just not stated so, but could you try using another browser or computer to test if the problem is specific to Internet Explorer (which you said you are using).



    Do you have any custom extensions/add-ons installed on your IE7/Firefox/Chrome?



    October 2010 I suddenly stopped being able to use URL link uploader on WP v 3.0.

    I used to be able to get a green “check mark” after verifying the exact url path of the image link in question. Now I get a red “x.”

    The only way to workaround it was to upload images using file uploader, which WP seems to only recognize when uploaded to the wp-content folder. This is annoying as I do not like to direct people to this internal layer of my server and prefer to use a simple domain/images file path.

    In any case, I have discovered that this might be an Firefox issue.

    I logged into Safari v 5.0.2 and the URL image uploader works fine. I get the “green check” mark that confirms the image link is valid.

    I hope this helps.



    @aux88 since you are using WP 3.0 – it means:

    Your site is not hosted on WordPress.COM, this site is for support of sites hosted on WordPress.COM. You should address your questions to WordPress.ORG the keepers of the software you are using:

    For more on the difference:

The topic ‘Image upload not working – times out’ is closed to new replies.