Need help? Check out our Support site, then

Image url

  1. Hi,

    I'm trying to upload single images into a blog from url. I am clicking on Add Image > > From URL > then I'm pasting in the url of the image I want to insert (

    But then I just get a red cross on the left of the 'Image URL' box as if to suggest it doesn't recognise the url. I have tried this with individual image urls from both my Flickr and Picassa albums.

    What am I doing wrong? Any help would be greatly appreciated!

    Thanks _ Paul

    The blog I need help with is

  2. Please paste the exact URL of your blog when asking questions here - or link your nickname to your blog as explained in the Sticky 8 Things to Know. We usually need that to give a relevant answer.

    The URL you're trying to use is the address of a webpage, not an image.

  3. Ok, sorry. My blog is here: ...

    If this link ( isn't a url to my photo in Picasa then I'm not not sure how to get the url? Next to the photo in Picasa it says 'Link to this photo' - the same in Flickr, and it give my this link.

    How do I get the url for my photos in Flickr or Picasa then?

    Thanks in advance.


  4. You have to save the photo to your hard drive and then upload it to your post or media library.

  5. If you need help uploading, you'll find it here:

  6. @paulparkie: You need the direct URL, i.e. an URL that ends with "jpg" - the URL of the image itself, not of a page that includes the image. If Picasa won't give you that, you can find such an URL if you look at the source code of the page:

    But I don't think it's worth the trouble: better do as ellaella says.

  7. I'm just repeating advice from on high. :)

    This very issue came up just a few days ago and tellyworth advised uploading from the computer:

  8. I think I know what u (Paulparkie) mean. The uploadscript is not working properly. Uploaded files get placed in the 'wp-content/'-folder while the post is refering to 'wp-content/uploads/....jpg'. This is a serious problem and has got nothing to do with uploading right or wrong. I have the same problem and can't fix it due to the fact that I can't find the script that says where the uploaded files are placed.

    Does anyone have an answer (pretty please)?

  9. Ok, I have found the answer, do the following:

    Settings -> Miscellaneous and make these changes:

    Store uploads in this folder: wp-content/uploads
    Full URL path to files:

    Good luck

  10. bnwiersma - that information is not correct for blogs hosted at wordpress.COM. Please take a look at the sticky at the top of the forums for an explanation of the difference.

Topic Closed

This topic has been closed to new replies.

About this Topic