Image widget worked and then stopped working

  • Author
  • #1124075

    I have had an image widget in my sidebar (theme: Splendio) and it worked just fine. Last night I went into one of my other widgets and made a minor change (changed to not display follower numbers) and since then the image won’t display.

    I’ve tried deleting the image widget and then setting it up again. I’ve also tried reinstating the number of followers. Nothing has worked.

    I can’t see that it’s anything related to my computer or settings since it worked fine and then all of a sudden it didn’t.

    Any thoughts?

    The blog I need help with is



    Each widget is completely separate: a widget cannot have any effect on a different widget. This is the URL you’ve used in the Image widget:
    This URL gives a “Not Found” response, so you’ve probably deleted the image from your media library. You need to re-upload the image from your computer via Media > Add New and copy the new URL you’ll get.
    By the way, better rename the file into something meaningful before uploading it.


    Thanks Justpi. This is confusing because the image is definitely still in my media library as that’s where I copied the URL from when I set up the widget the second time. I haven’t deleted any images at the time that the widget stopped working. I did delete some other images but they were different ones and on a completely different day.

    In any case, I’ll now upload the image again, rename and it try that way. Will be good but even more confusing if it works :D



    You’re welcome.
    Note: rename first then upload.


    Yeah, sadly didn’t work. The original image was still there. I deleted it. I changed the name of the file then uploaded it, copied the shortlink but no go. Will try again with the full url.


    Ah that worked with the full url. Weird but good. Thanks again Justpi.



    It’s not working because you used the shortlink, and the shortlink of an attachment page at that. The right URL is this:



    Ah, you beat me! You’re welcome.

The topic ‘Image widget worked and then stopped working’ is closed to new replies.