Images don’t appear in email

  • Author
    Posts
  • #535603

    proshowthink
    Member

    I’ve double- and triple-checked my settings, but no matter what, the email sent out when I add a new post excludes any images in the post, opting, instead to show up as the URL for the image in my media library followed by this statement:

    “* Some media is not displayed in this email and must be viewed on the website.”

    There’s nothing peculiar about the images–just simple jpegs.

    When I receive email from other blogs, any images in the posts are included, so it sure isn’t a setting in my email client.

    What am I missing here?

    The blog I need help with is framelockernews.wordpress.com.

    #535763

    airodyssey
    Member

    Hi. Could it be that the settings on your end are doing that?
    https://en.forums.wordpress.com/topic/posts-received-by-email-dont-have-images?replies=3

    #535825

    proshowthink
    Member

    I don’t think so. I receive email from another WordPress user whose images always show up in the mail. I’m using Outlook Express and haven’t had any problem at all with either attached or inserted images. This is the first time ever.

    #535907

    timethief
    Member

    May I suggest that you contact Staff about this please? http://en.support.wordpress.com/contact/

    #535962

    proshowthink
    Member

    Contact staff sounds like something really logical. I’ll do it. Thanks for poking at me with this.

    #535964

    timethief
    Member

    @proshowthink
    Best wishes for a a happy ending. :)

    #535965

    proshowthink
    Member

    Thank you, timethief. I’ve written them, but in the meantime, I’ve chosen “Summary” and am using excerpts to avoid the nasty looking note about some media not being able to be displayed.

    #535966

    timethief
    Member

    Good thinking. :)

    #536010

    proshowthink
    Member

    No answer so far. Either they don’t know the answer or they’re inundated with support mail. I suspect the latter. In the meantime, I suppose my plain-vanilla email alerts work well enough.

    #536011

    proshowthink
    Member

    I’ve now tried everything I can think of to get images into either summaries or manual excerpts. I’ve switched to the theme a friend uses whose images show up in email. I’ve changed my settings wherever there’s the vaguest of associations (in my mind) with post content. No matter what theme I use, no matter what settings I change, images aren’t included in the email even though I can see images in everyone else’s. (Thus it’s not my own email settings.)

    Surely I can’t be the only person in the world to have hit this brick wall. :-(

    #536012

    proshowthink
    Member

    By the way, here’s a perfect example of what appears in the email no matter what settings I choose. In this email example, you can see the URL to the image followed by the bit of text I added alongside it:

    http://proshowplaza.files.wordpress.com/2010/11/brazilian-thumb-1.jpg&h=112 Used link (file URL) to the image, then added FL link when writing post.

    * Some media is not displayed in this email and must be viewed on the website.

    #536013

    proshowthink
    Member

    P.S: The live link you see here is not in the least live in the email.

    #536014

    allnoodles
    Staff

    The image you linked to is on a private blog. Are you also sending out emails from the same private blog? If so, this would be why your images do not appear in the email, and why you get the message saying that some media is not displayed.

    #536015

    timethief
    Member

    @john
    Thanks for wading in here. :)

    #536023

    proshowthink
    Member

    What you’re seeing is the result of testing on a private blog. I’m getting the same results with my public blog. At this point I’m so frustrated that I’m considering switching over to Blogger, though in every other way, it’s not at all my best choice. :-(

    #536026

    allnoodles
    Staff

    Support tried contacting you on the 7th asking for details, but there was no reply – I would check your spam folder in case the response appeared there.

    I can see that you did have your blog set to private. Did you publish a post after it went public? If you did then send the URL of the post to support, along with a copy of the email you received, and they will be able to take a look.

    #536036

    proshowthink
    Member

    John, sorry for not answering sooner. I buried myself in work.

    I never received the mail, and since I don’t use spam software, that’s not the culprit. No doubt a hiccup occurred out there in the ether.

    In the meantime, it’s completely resolved. All I needed to do was go public for the images to appear. That said, it might be a good idea to either change this behavior for private blogs or warn people about it so they don’t go nuts trying to figure out what’s wrong. :-)

    Thank you for responding.

    #536037

    kenbas
    Member

    Sorry proshowthink, when you say:”All I needed to do was go public for the images to appear.”

    Could you explain ?

    Thanks

    #536038

    airodyssey
    Member

    @kenbas: He probably means for the blog to be Public (visible to everyone) as opposed to Private (visible only to those authorized):
    http://en.support.wordpress.com/settings/privacy-settings/

    #536039

    timethief
    Member

    @airodyssey
    Yes that’s exactly what proshowthink meant. :)

The topic ‘Images don’t appear in email’ is closed to new replies.