Need help? Check out our Support site, then

Import from Posterous throws an error Could not read the XML file


    I'm trying to import Posterous but it constantly gives me an error for wordpress_export_1.xml:

    Sorry, there has been an error.

    Could not read the XML file. Please make sure you are uploading a valid .xml or .xml.gz file. For more info, please see our documentation.

    The blog I need help with is

  2. Same here :(

  3. and here

  4. Getting the same thing as well.

  5. Do we know if anyone is looking into this? It would be nice to know because for an outsider looking in and considering a hosted and managed platform I'm not actually convinced so far. Support that goes round in a loop, no ticketing system. Does this change when you physically pay for a subscription? I've used SaaS from a WordPress competitor before and so far, I found it superior.

  6. I found this page a posterous.

    When the file was processed it did not find any errors but I created a file from the output and it uploaded to wordpress and is now processing. I'm waiting for it to finish.

  7. Just want to add my voice. Same here. I tried Tidy, as tortoise2013 suggested, to no avail. Curiously, a previous backup (form January) works, but not a new one. I tried both when my WordPress blog was empty, and now I published a test post. Does anyone know if we need to have an empty blog to be able to import? Does it matter if any of the blogs is password-protected / private?

  8. Yep mine failed to import as well. It was hope for a while at least :(

  9. Hi tortoise:

    Thanks for this. As I read it, it's designed for porting content over the other way -- i.e. from WordPress to Posterous, rather than the other way 'round. However, the Tidy utility seems designed to clean up problematic XML files, so I thought I'd give it a go.

    I took the contents of the XML file generated by the Posterous backup function -- you know, the one that none of us have been able to import into WordPress -- and pasted it into a plain text file, which I then ran through Tidy. I saved the results as a new file and then gave that an .XML extension.

    Then I tried bringing that into WordPress using the import tool, and it seemed to work -- I didn't get the error message we've all been getting about a problem with the XML file. Within an hour I got an email message telling me the import had been successful.

    Only thing was, it didn't make any difference. There are no new posts and no new content on my WordPress blog as a result. So, don't know what to say. Perhaps others can try it and see if they have any better luck?

  10. Same here.

  11. My main issue is that the Posterous XML files changes all of the apostrophes, Hawaiian, Japanese and other characters to "???" – which basically renders the import super buggy.

  12. Hi all, thanks for your patience while waiting for the response. I have replied to everyone on this thread who stated that they were unable to import their XML files directly via email, so that I can take a closer look at your backup files and help you move onto Please reply to that email whenever convenient (I am going to close this thread, anyone else needing help please start a new forum thread).

    @david5h: we have Community Forums support, where both volunteers and Happiness Engineers help, and we also have direct email support for users who have purchased upgrades on

Topic Closed

This topic has been closed to new replies.

About this Topic