Import from self-hosted blog leaves hard links

  • Author
  • #1473871


    I used the export/import method prescribed to import my wife’s blog into The site is there at the gosh-awful address

    and the home-page content is correct, but as soon as I click on a link in it, it takes me back to the original site at

    This is obviously not useable.

    What to do?


    Are you only seeing links in the content set up this way? If so, it’s likely that they might be hard-coded into your content. Could you check your links in your posts (by visiting your post edit screens for the posts in question) and see if the full link is there? If that’s the case, you’ll need to change them individually.



    Also, comments were not imported.



    When I look at the html (text), I see links like this:

    < a title=”Prologue: A look back in history” href=”″ >

    Is that what you mean?

    Actually, my wife is using WP in a rather non-bloggish way. The link example is from the _only_ post, which is essentially a table of contents with links to “chapters” which are pages, not posts. Does that explain the problem?

    There are not so many that I cannot change them by hand.

    But where did the comments go?

    Thanks, Lettergrade.



    Ok for the comments. Sorry, I did not scroll down far enought. The format is different… but I will soon fix that.


    Whoops, can’t see what you’re posting. Please use the ‘code’ button above when you’re posting code here, and I’ll check it out for you!



    Why is it called akismetuser540414415? How do I change that? Or is that another topic?



    It looks like you may have inadvertently created a blog with your Akismet login, without previously setting up a account.

    To change the website address (and the corresponding username), you can do so by following the instructions here:


    If you want a different url, here are some areas you can look into:
    Changing a Blog Address
    All About Domains

    And unfortunately, it looks like those links are manually coded into the content, and will need to be changed by hand. But a find-and-replace could be done to replace the old root url with the new one.



    Also, it looks like the reason the links aren’t working is that they are anchor links. You will need to modify those by hand because to, they are like any other link you might have put on the page linking to another site, not to an internal page.


    Ok, I guess my questions are answered.

    I have to do those “hard” links again. No problem.

    The comments are included.

    Thanks a lot.



    You’re welcome! As lettergrade noted, you should be able to fix them up pretty quickly by copying the HTML code to a text editor and doing a search and replace.

The topic ‘Import from self-hosted blog leaves hard links’ is closed to new replies.