Need help? Check out our Support site, then

Impossible to Make Line Breaks in Posts

  1. @philmartin
    Since you are self-hosted and using the software downloaded from, you need to direct your question to . uses a multi-user version of the software which is different and few, if any, here know anything about it.

    7 Things to Know Before Posting in Forums or The difference."

  2. @philmartin
    I just read your post a little more carefully and thank you for posting it. Although here on, we do not have access to any of the php files, it is a good thing for staff to know, and since I also have my own self-hosted blog with this problem, I now have a fix to try out. Once again, thanks for posting this and please post it to the forum as well.

  3. I had this same problem and I'm using Leopard 10.5 Safari 3 (non-beta). I found that in order to do a paragraph break I had to put my cursor in front of the first word of the paragraph I just wrote and click on the tinly little P that appears below the text box... it highlights the whole paragraph. So I'm assuming that's how it's done on Safari 3. Haven't had any problems since doing that.

    My first hour of setting up and writing my first post was annoying because it wouldn't hold the paragraph breaks.

  4. @deesfirstflight
    Thanks so much for posting that I'll have to give it a try.

  5. Hmmm, I'm on Safari 3 also, and it's not working for me, it still takes out the extra line and makes everything one paragraph.

  6. Are you typing with normal breaks? Hitting the return key? Do the P thing after you're finished writing.

    After I do that, and I'm finished typing I go back up to the first paragraph and put my cursor at the very beginning of it. At the bottom of the text box is the word Path: P <--- I click on that and it highlights that first paragraph... then I move my cursor down to the next paragraph... click on that P and it highlights the second one... etc....

    I'm in Visual mode when I do this.

    Save and Continue Editing and see if it holds. It's been working continuously for me this way. Weird way to do it.

  7. Yup, that's exactly what I did, and it did nothing for me.

  8. wow!... hmmmm

    I'm all new to this, figured that was the way to do it.
    I just tried it again....... this time doing nothing, and it held. Wouldn't group it all together so now I'm confused!

    Do I use the P thing or not?

  9. Are you using the visual rich text editor or the basic editor ("use visual rich text editor" deselected in users > my profile?

  10. I have it selected...

  11. What's the actual version of Safari that you are using? (Safari menu > about safari).

    I'm on 3.0.4 (532.12) running 10.4.11.

  12. I'm running Leopard 10.5.1
    Safari is 3.04 (5523.10)

  13. My time is off on the forum posts... I can't figure out how to change it... I mean... I had -7 but I don't think that's right????

  14. The forum is on UTC time just as your stats are and we cannot change this.

  15. For example although it's 11 AM where I live my posts here are 7:00 PM

  16. I'm having the same problem. Early posts worked just fine. I could either just hit return and wordpress was smart enough to figure out that I really meant <br>. Or, I could actually edit the code and things were fine.

    Now, my posts are all one big mess. And, if I try and edit the code, it doesn't work! Well, it looks like it works. When I preview it works. But, then it looses the changes and goes back to the original or worse, with partial tags showing.

    I'm using Leopard 10.5.1 and Safari. I read that if I used Firefox it would work. Maybe I'll give that a try. But, come on, it's not like Safari/KHTML/WebKit is a niche product any more

  17. The problem is that Safari has been slow to adopt some of the java and javascript support that is used in some of the more advanced online editors out there like the one used here at, TinyMCE. Now that Safari 3 is out of beta, it is my understanding that they are going to work on making the editor work with Safari. I don't know how long it will take, but I'm hoping not too long as I like Safari.

  18. Same here... I only use Firefox for my online schooling as Safari for some reason won't load the campus website at all... I dunno...

    But as previously stated for me... still works... seems to only work if I force justify the paragraph tho...

  19. For those coming to this thread in the future, I have my doubts that when the TinyMCE editor is updated to support Safari, that it will support any versions prior to 3. There are too many "things" missing or not properly supported in Safari 1 and 2.

  20. Hi, i'm having a problem too and i'm using Firefox! No matter what i do, i can't make the breaks so all my text is lumped together.

    I've tried putting them in using the 'code' tab but i won't work.

    Is there no simple fix? I'm not a techie and most replies on this thread go above my head!

  21. I have the problem as well with Safari. I make the breaks in the code window with <br> but the editor strips them out when I save. Also <p> I will try Firefox. I had stopped using Firefox because Safari seemed more stable on my Macbook.

  22. I also had problems with line breaks (<br></br> tags) and non-breaking spaces ( ). The editor removed all of them and squeezed all my paragraphs and lines together. I would put these back, but as soon as I enter the edit mode again, it would do the same thing. IT HAD A MIND OF ITS OWN, and IT WAS FRUSTRATING!

    The solution: Turn off the Rich Text Editor. WHO NEEDS IT ANYWAY?

    After this, I had full control of all my editing, as well as the HTML tags.

    Hope this helps

  23. Firefox works fine for me with the visual editor, but Safari still has the issues.


  24. I'm having the same problem with my site. I'm using the editor and I've tried going to code section and using the normal <br>'s, but they get stripped out and crunches my lines together.

    When I'm in the Visual section, with the Advanced Toolbar open, the bottom left corner has Paragraph unless I change it to Heading # or whatever. This causes all Enter's from the keyboard to result in new paragraphs with a spaced line between them. If I hold shift+enter, it gives me a new line without the space, but I can't use that to artifically increase the space between sections. I assume it treats it as a <br> and ignores it.

    It makes it quite difficult to break up sections of my post and I'm not sure why it's like that or how to fix it in Firefox (newest version).

  25. @buzzdome
    Download and use Firefox or Camino


    Or download and use an offline editor such as Qumana (free) or Ecto (about $20). Timethief has a nice review of all of them both for Windows and Mac, here: .

    Not everyone is comfortable, or knows anything about html, so turning off the editor is not a real option for them.

  26. I have used both types of browser IE7 and Firefox and in both cases, I was still having problems getting my page breaks, and line breaks. I am a web designer, so I knew how to put the html codes in the EDIT (source) portion of the post, but its still would strip them away. I saw the solution posted by timethief on November 14th, 2007 at 6:48 pm

    This works. Go to your...
    -> Dashboard -> Users -> Your Profile
    On the right hand side of the page find the checkbox for:
    --- Use the visual rich editor when writing
    and uncheck it. Then click "Update Profile".

    Thanks Timethief.

  27. I'm using firefox. I just followed the directions of itsgotime (taken from Timethief) and turned of my visual rich editor. It still doesn't help. I've tried both the <p> & <br> tags. They don't work (whether closed or not).

    Any further advice would be appreciated.


  28. PS I'm using Windows Live Writer. It all looks fine when I send it to WordPress. It's just after it arrives that the smushing begins.

  29. I had the no-breaks problem on a post today too. No problem with that, previously.

    I tried unchecking as suggested above. Then I re-checked. I really prefer visual rich editor.

    Then I posted a ps about the formatting problem on my post; it appeared with a line-break....

    Other line-breaks were then also mysteriously do-able.

    So the problem has resolved, for now.

    Using Firefox on Mac OS X.

Topic Closed

This topic has been closed to new replies.

About this Topic