Indenting Paragraphs

  • Author
    Posts
  • #407979

    sthomp07
    Member

    How do I indent the paragraphs? I need to have a space between paragraphs and an indent for each new paragraph. Thank you!

    The blog I need help with is sthomp07.wordpress.com.

    #408126

    Is this the blog you are talking about http://sthomp07.wordpress.com/ ?

    Blank lines between paragraphs should happen automatically in the visual editor when you hit return at the end of a paragraph. If it does not, select everything in the post, and from the “format” pulldown at the left end of the lower row of icons above the text area select “paragraph.” If the lower row of icons is not visible, click the icon on the far right end of the upper row (kitchen sink) and that will show the second row of icons.

    For a first-line indent on paragraphs, you will need to manually insert the proper HTML for each paragraph as explained here: http://wpbtips.wordpress.com/2009/06/19/formatting-text-pt-2/ (see first-line indents).

    #408147

    sthomp07
    Member

    That’s great!

    Where do I go to edit? Do I just clicl edit beneath each post and insert the link?

    THank you os much!

    #408148

    You have to open the post in the editor, switch to the HTML tab, and then add the code that is shown in the blog post to each paragraph.

    You need to put this <div style="text-indent:2.3em;"> at the beginning of each paragraph, and this </div> at the end of each paragraph.

    #408149

    You might also have to adjust the 2.3em number for your tastes.

    #408152

    Actually don’t do the above. Do it this way

    This at the beginning of each paragraph<p style="text-indent:2.3em;">and this at the end </p>

    That will preserve the paragraph spacing.

    #408154

    You know, I must be brain dead today. Put this at the beginning of the post in the HTML editor <div style="text-indent:2.3em;"> and then put this at the very end of the post</div>

    #408236

    sthomp07
    Member

    Hey I have another question. I switched themes and the first paragraph of each blog is in a darker font. How do I change this? Thanks.

    #408237

    Wow, that is interesting. It took me a few minutes to figure out what was going on.

    The first paragraph, is not surrounded by paragraph tags so the paragraph formatting set in the CSS is not being applied to it.

    First off, go to settings > writing in the dashboard and click “WordPress should correct invalidly nested XHTML automatically” and click save changes.

    Open your posts and in the visual editor, select all the text and then from the format pulldown (left end of lower toolbar) select “paragraph” then save and preview the post. The problem should have gone away.

    The change at settings > writing should keep this from happening in the future.

    #408238

    sthomp07
    Member

    Great I will do this. But I have yet another new problem. I am doing a works cited page after each blog (this is a university project), but when the urls for website disappear. How do I make the website name appear, without a hyperlink? Thanks again!!

    #408241

    sthomp07
    Member

    I also cannot find the format>paragraph option for the above solution.

    #408242

    It’s at the left end of the lower toolbar in the editor: http://opposablethumbz.wordpress.com/files/2009/10/format-icon.png .

    On the links thing, I’m not sure what you mean exactly. If you want the website name without a link, then just type the name into the editor.

    #408243

    sthomp07
    Member

    Thanks so much! You’re a great help.

    #408244

    You’re welcome and thanks.

The topic ‘Indenting Paragraphs’ is closed to new replies.