Need help? Check out our Support site, then

Insert image/link not working

  1. Hello guys,

    My inset Image/Insert Link button is not workin :( Why is this happening? After I copy the image/link to the box and click "insert", it doesnt work and the box keeps re-appearing!
    Can someone please help me?

    Thanks a lot!

  2. Try logging out, clearing your browsers cache and start from scratch.

  3. Thank you for your help! I appreciate it...

    But it's still not working :(

  4. Wierd, I just made a post this evening that contained an image and it worked fine.

    Double check the link that you are using for the image.

    Otherwise, you could always drop a message to the support desk.

  5. @ruhi
    The instructions as laid out in the FAQs for uploading images start here

    If you have followed them to the letter and still are not succeeding then you could try shutting off the text rich editor and starting over again using the ordinary editor. To shut off the text rich editor -> dashboard -> options -> profile and uncheck the visual rich editor box -> click update profile

    If neither of these work then I recommend sending in a feedback.

  6. @ britishbull,

    The link that Im using is fine..there is no problem with the link


    I have followed all the directions to the hilt; infact I have used this option many times before...but this is the first time that Im facing this issue.

    The unchecking of the visual rich editor did work!! Thanks a lot for that; but how do I go about posting in it? Just like I used to when the visual editor was on?

    I couldnt possibly write (by turning the Visual Rich editor on) and then insert pics and links (by turning it off?)

    I did inform the Support Group though.

    Everybody, thank you very much for your valuable help! :D

  7. Oh, I've been dealing with this issue for days. You can still use the rich text editor, but you have to do every paste twice. I don't know why that is; I'm finding it's the same today even for text.

    Most annoying.

  8. @rain
    tiny mce and "buggy" seem to be synonymous - I take it that feedbacks have been sent in, right?

  9. Starting a couple of weeks ago. No response, although I see that threads on the issue are marked "resolved."

  10. hmmm ... 2 weeks and not resolved is not good ... bump to drmike tomorrow am? I can do that but I am off to bed now before I drop in my tracks g'night :)

  11. It seemed to be fixed, but it has begun happening again starting a couple of days ago.

  12. bump to drmike

  13. Yeah, I havent heard from the support team; and the buttons are still not working :( I tried doing it like 3-4 times; it still doesnt work. I keep switching betn. rich text and the plain version whenever I need to post :(

  14. You have to click within the text box of the post where you want the picture before you send the information over. This tells WordPress where you want the link.

  15. I've been doing that, but I think you've put your finger on it indirectly. Sometimes the cursor just vanishes or moves from centered to left-aligned, as I'm getting ready to upload. I always click again where it should be, but the two weirdnesses might be linked.

  16. @drmike,

    I have done all that before; like I said, this is not the first time that I have used this feature :) It's weird how the button just wont work! :( Thanks for your help!

Topic Closed

This topic has been closed to new replies.

About this Topic