Insert/edit link dialog in visual editor navigates away from Edit Posts

  • Author
  • #1238094


    When editing a post in the visual editor, I select text that I wish to make into a link, click the “link” button to bring up the Insert/edit link dialog, and enter the URL, etc. But when I click Add Link, the page navigates away from editor on the Edit Posts page and back to the Posts page, incidentally losing any other edits!

    I notice that others have had similar problems over the years, but all those topics are closed and none of the solutions worked. I tried disabling all Chrome extensions, clearing the cache, restarting the browser, etc. The same problem occurs in both Chrome and Firefox.

    Suggestions appreciated, thank you.

    The blog I need help with is






    I also tried this in Opera, freshly installed, and it doesn’t work there either.

    I also have support topics open for widgets failing to drag to the sidebar, and appearing blank except for the header after I log in. Are these all related?

    I am trying to add a PayPal “Donate” button to my blog. In order to do so, I need either to edit a text area in the sidebar, or else edit links in the page. I am frustrated that before I even get to seeing if the code I got from PayPal works, I can’t get the basic editing functionality of WordPress to work in the browser!

    Help appreciated, thanks.



    Exact same problem here.
    Tried reinstalling the wordpress files (bar wp-content) to no avail.
    My understanding is it could be a plugin conflict – after having updated wordpress – but none of the plugins seem to be causing the issue.
    Anybody found a soultion?



    I eventually traced the problem to… of all things… my phone. When I connect via Fido with my Samsung Nexus S with Android 2.3.6 tethered (either USB or WiFi) then I get the problem. When I connect with any other network, no problem. The very occasional time I NEED to use my own connection, I put the SIM card in an old phone, tether with USB, and it’s fine. Mostly, I just wait til I am going out to borrow some WiFi on another network to edit my blog. At some point, I will update my Android, and it should clear the problem; but notwithstanding a few oddities, I rather like that release of Android so I am not rushing.

The topic ‘Insert/edit link dialog in visual editor navigates away from Edit Posts’ is closed to new replies.