Need help? Check out our Support site, then


Intergalactic in-post image editing and published post alignment problems

  1. I really like the Intergalactic theme because it does such a great job of presenting photography, but I'm having a couple of issues with it that I'm hoping to get help with:

    1. The image editing buttons (align, pencil, and delete buttons) disappear from the visual editor. After I've inserted an image, I can still see those buttons, but once I've edited the image once (for example, deciding to go back in and add a caption or changing the alignment of the image) the image gets really large and the image editing buttons don't appear. So I can't figure out how to change the caption at this point.

    2. I've found that unless I include a caption with the images in the post, the presence of a large image makes the post too wide, and introduces a horizontal scroll bar (with mouse) or swipes to the left (with a laptop touch pad). When this happens, there's a bunch of white space and the content becomes off-center. This is at the full browser width -- if I make my browser narrower the problem goes away.

    But with a gallery or adding a caption to the image, things stay in place like they should: http://amylamp.com/2015/01/21/herringbone-and-denim-ipad-sleeve/

    This was complicated to type out, so I hope it makes sense. Any help would be appreciated -- thanks!

    The blog I need help with is amylamp.com.

  2. 1. The image editing buttons (align, pencil, and delete buttons) disappear from the visual editor.

    This is almost certainly a browser issue, or some other issue affecting only the device you were using at the time. Try again after doing each of the following:
    1. clear the browser cache
    2. update the browser
    3. switch to a different browser
    4. Use a different PC or device if available.

    2. I don't know how you created the off-centered image, here, but that this effect should happen if you don't include a caption doesn't make sense.
    In the second example you provide under item 2, is the caption you are referring to "Casual, classic, and tailored ensemble," below the small picture demonstrating a denim-navy-and camel combination>

  3. Correction to the response to your second item:

    2. I've found that unless I include a caption with the images in the post, the presence of a large image makes the post too wide, and introduces a horizontal scroll bar (with mouse) or swipes to the left (with a laptop touch pad). When this happens, there's a bunch of white space and the content becomes off-center....

    I don't know how you created the off-centered image, here, but that this effect should happen if you don't include a caption doesn't make sense. In the second example you provide under item 2, is the caption you are referring to "Casual, classic, and tailored ensemble," below the small picture demonstrating a denim-navy-camel combination?

  4. OK, thanks for the browser suggestion to get the image editing options back. I tried those things, and had slightly better luck on a PC (normally I work on a Mac) -- the edit buttons are there but the image is still huge in the post edit area.

    I also tested out switching the theme to the Twenty Fifteen theme to see if the problem still appeared with that theme on my Mac, and the problems went away. So that leads me to believe it's an issue with the Intergalactic theme.

    Regarding the second item, yes, "Casual, classic, and tailored ensemble" is the caption. That off-centered image happens when I scroll or swipe to the right while viewing the live post -- it moves the content to the left as if there's more content there to show, but there isn't.

  5. the edit buttons are there but the image is still huge in the post edit area.

    You can edit the size of any uploaded image. If an image looks abnormally large in the post editor window, that indicates 1. that you uploaded an extra-large image, and 2. you probably uploaded it at full size (though you may have increased the size or set it to full size after uploading). I think WordPress retains the size at "Attachment Display Settings" in the "Insert Media" module which you selected on the previous upload. I usually keep my image size setting the same for every upload, medium, and make any necessary changes after uploading and embedding the image. If you do the same, and suddenly find that images are uploading at a larger size than usual, you may have accidentally changed the size setting.

    That off-centered image happens when I scroll or swipe to the right while viewing the live post -- it moves the content to the left as if there's more content there to show, but there isn't.

    Well, I haven't been able to reproduce that effect when viewing your website on my PC. I just checked several posts and pages randomly (2 posts, 2 pages) and everything looks normal. The featured images are displayed at full width, and the embedded images (none of which have captions) are centered and medium-sized. I've yet to see a scroll bar on any image, page, or post, on your site.
    Were these effects also present on a PC? What kind of device are you swiping on when you see image become off-centered?

    I'm going to tag the topic (thread) for Staff attention, since I think you might need assistance which I may not be equipped to provide.

  6. It was actually at least 10 total posts and pages I visited on your site (5 posts, 5 pages), because I went back and checked some more as I was writing the last post.

  7. HI alamp - I'd like to try to get to the bottom of your issues in Intergalactic so we can get this fixed up if it's indeed a bug.

    Let's start with the first issue.

    To help troubleshoot, could you please tell me step-by-step exactly what steps you're taking before you see that too-large image in your editor?

    For example:

    1) Navigate to the wp-admin editor
    2) Click Posts > Add New
    3) In the Visual Editor, click Insert Media
    4) Choose an image from my Media Library and insert at full size with these settings: https://cloudup.com/cp0WqPcyRKw
    5) Click Insert into Post
    6) Publish post
    7) Click the image to activate image-editing buttons
    8) Click the pencil icon
    9) Change size to Medium and Centered: https://cloudup.com/cOvbko_3pRX
    10) Click Update

    Following these steps I wasn't able to replicate your issue on Mac 10.9.5 with Firefox 36.0.1.

    Having the exact steps that trigger the size issue for you will help me replicate, which will hopefully lead us to a fix. Thanks a lot!

  8. Could you also please link to the image in your media library that you tested with for issue #1? Thanks!

  9. 2. I've found that unless I include a caption with the images in the post, the presence of a large image makes the post too wide, and introduces a horizontal scroll bar (with mouse) or swipes to the left (with a laptop touch pad).

    Could you please provide a link to a post on your site where this is happening so I can take a look directly? You can leave it set to draft if you like, and let me know what the title is so I'll be able to find it in your dashboard. Thanks!

  10. For reference, I’m on Mac 10.10.2, using Chrome 41.0.2272.89. I had also tested the post display/scrolling issue on a Samsung PC laptop and saw the same problem as on the Mac.

    Here are the steps I take:

    1. Navigate to the wp-admin editor
    2. Click Posts > Add New
    3. Type the post name in the Enter Title Here field
    4. In the Visual Editor, type my post content
    5. In the appropriate place in the Visual Editor, click where I want my image to appear
    6. Click Add Media
    7. Navigate to my desktop and drag the .jpg file to the Insert Media window
    8. Enter the Title and Alt Text for the image (Caption field left blank)
    9. Click “Insert into post”
    10. Uncheck “Allow trackbacks and ping backs on this page”
    11. Select the post category
    12. Add tags
    13. Set the featured image
    14. Save draft
    15. Preview the post (and at this point if I scroll to the right, the large blank space appears and the content shifts to the left, as seen with this example)
    16. Back in the Visual Editor, click the image to bring up the image editing buttons and click the Edit pencil
    17. Add a caption (the display settings are already set to Center, Full Size - 1536x1024, and Link To None) and save
    18. At this point, I can no longer access the image edit buttons as in step 16, and the image has gotten much larger in the Visual Editor
    19. Save Draft
    20. Publish and check post. At this point, the addition of the caption has “fixed” the side scroll issue and the post appears as it should.

    My steps are basically like your example, except that when I try to edit the image again, after the first time, I’m unable to.

    The image I used for that example in issue #1 is: http://typefan.files.wordpress.com/2015/03/ampersand-and-m-tea-towels1.jpg

    I have a draft post where I’ve been testing out this behavior here: https://typefan.wordpress.com/?p=1807&preview=true. I also created a new post to document my steps and published it live in case that made a difference: http://amylamp.com/2015/03/13/image-troubleshooting-post/

  11. Thanks a lot for this, it's super helpful.

    To start, I went through steps 1-15 in Chrome but I didn't get the blank area causing the horizontal scrolling that you're seeing.

    In step 7, at what size are you inserting the image? Maybe there's a difference there. For example, this is mine:

    https://cloudup.com/c-NQ3370IgJ

  12. For step 7, I choose "Full size" (there's no Large option for me, just Thumbnail 100x67, Medium 300x200, and Full Size at whatever size I've made my image in Photoshop).

  13. Could you please let me know your browser window size, which you can find here, next to "Browser window width:" and "Browser window height:"

    http://whatsmy.browsersize.com/

    Do you see any horizontal scrolling on this post, on the front end (public side) of your site?

    https://typefan.wordpress.com/?p=1807&preview=true

  14. Hi -
    Browser window width: 1272
    Browser window height: 601

    When I few that post on the public side, I do see the horizontal scrolling. But if I reduce my browser window to 1059, the horizontal scrolling goes away as the site responds to that smaller browser size. This makes me think it's related to the CSS for the /* Large screens */ @media screen and (min-width: 1060px) and/or /* Really large screens */ @media screen and (min-width: 1400px) …

  15. Thanks for those dimensions - very helpful and I've been able to replicate both issues now. I will report them to our developers so they can take a look. Thanks for your patience and attention to detail through this process.

    We'll keep you posted here.

  16. Awesome, thank you!

  17. Our developer has made a fix for the horizontal scrolling issue. Could you please have a look and confirm that the issue is gone and let me know?

    I will get back to you separately about the image-editing toolbar issue when I have more news.

  18. Excellent! I checked some posts that previously had scrolling issues and now they are fixed.

    And sounds good on the image-editing issue. I appreciate the update on that as well.

    Thank you!

  19. Excellent! I checked some posts that previously had scrolling issues and now they are fixed.

    Great! Thanks very much for confirming.

  20. Hi Amy, our developer has made a change in Intergalactic to fix the image toolbar issue, could you confirm that it's fixed on your end? Thanks!

  21. Hi - I checked the image toolbar issue on a few posts and that indeed looks to be resolved.

    Thank you for following through on these items! I'm so happy these adjustments were made to this awesome theme.

  22. Great! Glad to hear it. I'm going to close this thread now but if you need help with anything else feel free to start a new one!

Topic Closed

This topic has been closed to new replies.

About this Topic