Internal link changes when reading in "category" view, resulting in "not found"

  • Author
  • #867409

    It’s probably easiest to explain by demonstration. Look at any of my posts with titles beginning with “Exploring RV Living…” At the start of each, I note that they are part of a series, with a link to the introductory post of the series. That link works just dandy whe reading an individual post. It also works fine from the home page of my blog. If, however, you are looking at the category view, the link does NOT work.

    Compare the behavior of link “the introduction” between the individual post:

    or home page

    where the link works fine, and reading it in category view:

    where it does not. The URL seems to have the word “category” added in at the beginning where it doesn’t belong. If I remove that word from the “bad” url, it will find the correct page (in spite of all the extra dates also apparently added to the path)

    So… did I do something wrong? Or did I find a bug?

    Reading on the home page, works fine, too.
    Blog url:


    For clarification, all of the links I suppliedt above are fine – my issue is that the url attached to <i>the introduction</i> in the italicized opening paragraph of the described posts changes if reading the posts from their category page (vs. reading from home page or as individual post).



    Actually, the link is quite broken in all views. I suspect you may just have a good link still in your browser’s cache.

    I recommend changing the link to what it should be.

    Also, props on switching to DuckDuckGo. It’s a great little search engine.


    Thanks – I never thought to look at the actual link in the editor. I fixed it and it now works fine. At least on the one example – now I have to go check each article in the series (and maybe any other internal links in any post?). Of course that doesn’t explain the difference from one view to another of the same post, but no matter I suppose.

    I’m not sure how that could have happened, but I have two guesses. Either it is a result of my copy-and-pasting that italicized paragraph in from another post each time, else it is some strangeness that occured when I recently changed from to (still hosted on

    Thanks again – I’ll come back and mark this resolved once I’ve edited all the affected posts and make sure all works as it should.



    Perfect, I’m glad that worked!

    Typically, I advise against copying and pasting, since it does some weird things from time to time. If you do have to give that, give everything a thorough check before publishing.


    All fixed! Thanks again. While I was at it I updated some other links that weren’t really broken, but just to be consistent with my domain upgrade.

    I guess the real lesson I learned today is to always pick from the list in the editor’s link tool when linking to other of my own blog posts.



    You’re welcome!

The topic ‘Internal link changes when reading in "category" view, resulting in "not found"’ is closed to new replies.