Invalid/missing verification nonce

  • Author
    Posts
  • #2926951

    sowmyamishra
    Member

    I’m trying to connect my Twitter account on my blog in the sharing tab. But that is the error I see I don’t know why. Please fix it.

    The blog I need help with is thefashionpixieblog.wordpress.com.

    #2927078

    Hello Sowmya,
    Did you follow all the steps correctly given here: https://en.support.wordpress.com/publicize/#twitter?

    If yes, did you try reconnecting?

    Also, try clearing your browsers cache and cookies as it may be a browser issue sometimes. Then, login again and reconnect.

    Let us know if it works.

    Thanks! :)

    #2927081

    justjennifer
    Moderator

    It also helps to be already logged in to twitter when trying to authorize the connection.

    #2927087

    sowmyamishra
    Member

    I am already logged in on Twitter and yes I followed the same procedure and also tried it after cheating cookies but it still says the same. Invalid missing verification nonce

    #2927088

    sowmyamishra
    Member

    Clearing cookies*

    #2927091

    justjennifer
    Moderator

    Are both your twitter account and your WordPressdotcom site Public (not Private or Hidden)?

    What OS/browser are you using?

    #2927094

    sowmyamishra
    Member

    Nope they’re both public.

    #2927102

    justjennifer
    Moderator

    From my end, I just set up a new publicize connection to twitter without encountering any issue. I was logged into my twitter account and used the connect to twitter button on this page https://wordpress.com/sharing/

    Take a look in your twitter account settings>apps to see if WordPress.com is authorized there or not.

    Is this the first time you are trying to set up the Publicize connection to twitter?

    Please mention which OS and browser you are using.

    #2927103

    @sowmyamishra are you able to successfully login to your twitter account and authorize WordPress.COM?

    #2927105

    sowmyamishra
    Member

    I am using chrome on Android and this is the first time I am trying to set up the publicize connection to twitter.

    #2927112

    justjennifer
    Moderator

    I have a feeling that you’ll need to be logged in to both twitter and WordPressdotcom through the browser (and not through any app) in order to set this up.

    Regardless, I’ve tagged this for Staff assistance.

    #2927176

    supernovia
    Staff

    @justjennifer is right – can you try logging into Twitter via Chrome, and WordPress.com through chrome as well, then try authorizing once more?

The topic ‘Invalid/missing verification nonce’ is closed to new replies.