inviting follower to become author

  • Author
    Posts
  • #771169

    gdkrenz
    Member

    I’m trying to invite a follower of my blog to become an author. But when I try to use the “invite new” feature, I get an answer that says he already has a role on my blog. As far as I can tell, the only role he has is Follower. Any advice on making him an author?

    The blog I need help with is umphil196.wordpress.com.

    #771332

    timethief
    Member

    As an Administrator of a blog, you can change other users’ roles by following the steps below.
    Head to Users > All Users in your dashboard.
    Check the box(es) next to user avatar(s).
    Using Change role to… dropdown menu, select the new user role(s) you want to assign.
    Click Change.
    Changing User Roles

    #771339

    gdkrenz
    Member

    Thanks. The problem is that his name does not show up in the Users list, only in the Followers list.

    #771340

    auxclass
    Member

    You need to send an invite for a person to be added as an author etc – you can’t just promote a follower.

    #771343

    gdkrenz
    Member

    Right, but when I try to send the invite, it won’t go. I just get an error message that says he already has a role on my blog. Something seems amiss.

    #771346

    jonpageacabo
    Member

    Try to resend an invitation to the person you want to be an author.

    #771401

    justjennifer
    Moderator

    Perhaps the person has not yet accepted the invitation, which I believe they must before they appear in the Users list. There is also a possibility that your invitation went to their spam folder.

    Do they appear in the “Past Invitations” section of the “Invite Users” Dashboard?

    #771416

    jtsaohw
    Member

    I’m actually having the EXACT SAME PROBLEM! I invited several people to be followers in my blog, but only because I didn’t realize that changing them to be contributors later on was not an option.

    One of the people I invited accepted my invitation to be a follower, but when I tried to change his role to be an author, I just couldn’t. He doesn’t appear in the “All Users” section where you’re supposed to be able to change roles! The one place where he does appear (the “Site Stats” place) does not have any method for changing roles.

    I sent a new invitation to everyone I had invited, this time asking them to be Authors, and it worked! The catch is, it only worked for people who hadn’t already accepted my invitation to be a follower. For this person, it just said “User already has a role.”

    I think something must be wrong . . . seriously wrong.

    #771417

    gdkrenz
    Member

    Yes, that’s exactly it. I’ve emailed WordPress support but don’t have an answer from them. It seems that this should be easy to do: why not have invited followers in the Users list?

    #771427

    jtsaohw
    Member

    My thoughts exactly.

    Oddly enough, they DO include followers in the total user count. That is, there’s a number next to the thing that says “All users” in the “Users” section of the dashboard that tells you how many people are in that particular group, whether it’s “All Users,” “Administrators,” “Authors,” etc. Even though it’s not showing the followers, it IS still including them in the count.

    #771429

    timethief
    Member

    Hello there,
    Will you members please contact Staff directly for assistance and be sure to provide all the details that you can in your support ticket?

    #771456

    thedoormatt
    Member

    Hey, good news! I think I was able to solve the problem! I logged in as the other person (yes, I had their permission), went to “Manage My Blogs,” or something like that, and just removed my blog from the list. I was then able to send a new invite to him, asking him this time to be an author. No error message . . . No worries.

    So if you can just have the other person do the same thing I did, you should be able to re-send your invitation as well. It’s a little round-about, true, but hey! If it works, it works!

    Hope that helps!

    #771457

    jtsaohw
    Member

    Oh . . . sorry. The post above was from me. I was still signed in with his account . . . Awkward . . .

    #771458

    timethief
    Member

    Thanks for sharing how you resolved this.

    #771470

    gdkrenz
    Member

    Yes, many thanks. Now we just need to get WordPress to fix the problem.

The topic ‘inviting follower to become author’ is closed to new replies.