Need help? Check out our Support site, then

IO Error 2038 uploading mp3 file

  1. I have been trying to upload an mp3 file of 40.4MB and I get Error 2038. Please help.

  2. Can you make sure you have the latest version of Flash?

    Can you try using the Browser Uploader instead?

  3. I tried the Browser uploader and I got the same error message. I will check my flashplayer.


  4. I went to Adobe and downloaded the latest version of Flash. I then tried to upload my mp3 file again and I got the same 2038 error message.

    Any other suggestions?

  5. What is the filename? Sometimes doesn't like certain filenames, especially those with punctuation in them.

  6. The name of the file: Olivet Discourse - The Beginning of Birth Pangs Part 5 (Matt 24.10-14)

    So, I just renamed the file: 09-28-08.mp3 and tried to upload it again. The same thing happens.
    It uploads a about half of it and then it quits and gives me that bar that says, "dismiss." Then I click on it and see the #2038 error.

    Still unable to upload the file.

  7. As rain said, often doesn't like files with punctuation in them. Try renaming the file to 092808.mp3 and trying again.

    Also - are you sure it is an mp3 file?

  8. Thank you Vivian. I will try changing the file name as you said. Yes, it is an MP3 file.

    This is a file of speaking only. It is a message that our pastor gave last Sunday. Previously I uploaded one for him and it worked okay. In the meantime he got a new mp3 recorder.

    I've been comparing the two files and there are some differences and maybe we can find the answer there.

    First file:The Olivet Discourse - The Beginning of Birth Pangs Part 2 (Matt. 24.6-7b)
    As you can see this one had a very long name with a lot of punctuation, but it went through for me.
    Duration 40.39
    Type: MP3 Format
    Bit rate: 64 kbps
    Size: 18.6 MB

    Second File: 09-08-08
    Duration: 44.13
    Type: MP3 Sound
    Bit Rate: 128 kbps
    Size: 40.4 MB

    As you can see both of these files were about the same length in time. Both are MP3. But, the Bit Rates were a LOT different. And the size of the files were a LOT different.

    I'm wondering if the problem has something to do with the bit rate. (which I know nothing about.)

    These files are speaking words only. There is no music on them. So, what bit rate should he be using?


  9. The second file was encoded at a higher bit rate, which is why it is so large. For speaking, 64 kbps is fine. (The higher the bit rate, the higher the quality. The higher the quality, the larger the file.)

    But I suspect the problem may be the encoding. According to the FAQ ( ) the file should be encoded at 44.1kHz

    Check out the encoding and see what it is.

    BTW - have you tried to play the file on your computer?

  10. Hi Vivian, and thank you for your help.

    I tried the file in question on my own computer and it played using Windows Media player.

    I checked out the encoding on both of the above files.

    File 1 which was uploaded and worked:

    encoding: 24 Khz

    File 2 which I'm having all the problems with:

    encoding: 44.1 Khz

    So, what do you think?

  11. Hmm - I'm out of ideas. You should probably contact support.

  12. Okay, thanx.

  13. Did you indeed rename the file with no punctuation in it and try uploading that? In my experience a dash will always give you a failure.

  14. In the OP's post above with the file information, the only thing I see is the difference in file "types." One first is "mp3 format", and the second is "mp3 sound". I don't know if this is what is causing the second to be rejected, but if they were made on two different digital recorders, then I suspect there is some issue with the encoding or something on the second.

  15. Yes, I did. I renamed it. 092808.mp3 It gave me the same error message. It uploads about half of it I think.

    Also, could my screen saver be causing any of this problem?


  16. From

    Uploading of images and other files is currently limited to 3GB in total.
    Individual files up to around 75MB can be uploaded but this will depend on your connection speed.

    I don't know if this is the problem or not, but it could be that it is simply taking too long to upload and wordpress is terminating the upload session.

    I'll modlook this thread and see if staff will drop by and shed any light on the subject.

  17. I have 5GB of storage for files as I upgraded that so I could upload mp3 files. So, I have enough space. But, maybe it is because the file is large 40.4MB and like you said the wordpress system is timing out. I have broadband 1.5 from windstream, but I don't know how fast it uploads.

    It takes about 20 minutes loading this file to the point where it quits. So, maybe you are on to something.


  18. It's not the file size - I uploaded a 500 MB video to my blog the other day. There's something else going on. I really think you should contact support.

  19. I contacted support and they said to send them the file so they could check it. I did that and am waiting for a reply.

  20. Finally, I believe I've found the answer to my problem. Thought I'd share it with you all in case someone else has the same one.

    I turned off my Zone Alarm Security Suite and tried to upload the file again and this time it worked perfectly. Whew!

    Thank you all for your imput.

Topic Closed

This topic has been closed to new replies.

About this Topic