Need help? Check out our Support site, then

iPad cannot type in box while creating new post.

  1. I got my new iPad and thought it might be good for me to write directly on iPad. However, when I start a new post, I CANNOT select the field of text entry when it is on VISUAL mode. HTML mode works. This is very frustrating how it behaves. I can't type there in the box no matter where I touch. Anyone knows about this? Thanks.

    The blog I need help with is

  2. What browser are you using? Are you using the app?

  3. I am using safari to browse to word press. All other type boxes work but the main blog text editor box cannot be selected when it is in visual mode. If I switch to HTML then the text box can be selected. But visual mode is what I want to use.... So basically i can't write with iPad safari..

  4. @xtroar
    Have you reported your problem and all the details to Staff yet? If not please do so using this link >

  5. Just reported the problem. I believe that this is a bug as I have never experienced this on ther websites. Hope it will get fixed... :/

  6. Have you tried using the WordPress app? I've used it on an iphone and it's pretty good.

  7. I have tried it. The tech support suggests me to use the app but sometimes you don't get the whole feel of the blog while in a simplified app. Also the app itself is not very stable as it crashes often. The add picture function is also bugged.

    As a reputed blog service, I seriously think that word press should consider looking into this problem how iPad safari cannot type into the blog context box. I believe that it is an easy fix. May be iPhone safari has this problem as well.


  8. No, I can confirm from experience that both iPhone Safari and the iPhone WP app are quite stable.

    If you contact staff via the Help tab on your dashboard, they can look into it.

  9. I am experiencing the same problem on my ipad, should I contact support

  10. I have contacted the support and they suggests me to use the buggy wordpress app. I don't want to use the app because it doesn't give me the full experience of the site. And it is very buggy as well.

    They really should fix this.

  11. I have the same issue; a workaround I am using is to write my entry in the Notes app, copy it, then go to WordPress and paste. Works for me and some friends, but not for others.

  12. Following things don't work when using iPad and wordpress:
    Uploading images, for anything, gravitar, into a post
    Adding text to a post, white box problem
    Adding widgets, cant drag and drop

    Any suggestions? And don't suggest the app, that's just not as good as it should be (yet) :-)

  13. We Volunteers cannot help with these issues. Please reported your problems and all the details to Staff.

  14. Why not use the wordpress app for iPhones? Look through the forums over there and see if there is any entries on the iPad, but I'm sure it should work.

  15. Same here. The app is pretty useless unless you know how to write HTML. And the browser does not work with wordpress.

  16. I wonder if perhaps there's a Blogdesk or Ecto or WindowsLiveWriter app that you could use?

  17. I am having the same problem, plus the stats diagram doesn't come up in safari-iPad (but works fine on my other Macs).

    WordPress should fix this, surely?

  18. The stats are flash, and there is no flash for iPhone, iPad and iPodtouch.

    I expect at some point WP will change this to something other than flash but for now it's what we have.

  19. You can get the total number by going to for now.

  20. is where you should be checking, I assume.

  21. One of reasons I bought an iPad was to blog on boring commutes. As others have pointed out, stable or not the app gives a greatly reduced experience. People also seem to be getting 'mobile' device confused with 'small screen' device. The iPad is the former, the ipad is both. At 1024x768 the app is hardly an appropriate solution for the iPad!

    I persevered with text entry via safari in the main content text field and strangely, after numerous attempts I got the text cursor but the text kept shifting to caps. I would guess that safari is seeing this field as a password field somehow. I with other users though, this really needs attention and seems likely to be easy to fix.

  22. You need to lodge your complaints about the wordpress iphone/ipad app over at . We have nothing to do with that app here.

  23. Both modes need to work...the app for iPad is fine, but the browser experience needs to work as well. Jut as an FYI, you can't download an app, even a free app, from iTunes without a credit card.

  24. You need to lodge your complaints about the wordpress iphone/ipad app over at . We have nothing to do with that app here.

  25. Copying into Word Press on iPad only seems to work in HTML. The Visual mode refuses to accept text in the text box. Text did copy into the Title box and the Excerpt box. I was able to send text from my email to iPad Word Press also. This inconsistency is a bit frustrating.

Topic Closed

This topic has been closed to new replies.

About this Topic