Need help? Check out our Support site, then

Is it really possible to connect Klout with self-hosted WP blogs via Jetpack?

  1. I have a self-hosted blog with JetPack installed, a account and a account. Recently I read that JetPack allows users to finally connect the service to their self-hosted blogs. I tried doing that, but I received the following message:
    "That site does not seem to be accessible or no longer has the Jetpack plugin installed."

    I have the latest version of JetPack. It occurred to me, that I have so edited the PHP of my self-hosted blog, that the Home Page automatically redirects the visitor to the latest post. Is it possible that this causes trouble?
    Blog url:

  2. It's definitely possible. Can you try switching to a default theme, such as Twenty Eleven or Twenty Twelve, then try to connect Jetpack again?

  3. Hi, thank you for replying :)

    I just tried with Twenty Eleven, and again I got the same message. Is there a way to diagnose the cause?

  4. Thanks for giving that a try. You can enter your site URL here:

    In Settings -> Writing, can you enable XML-RPC and click Save Changes, then give it another try?

  5. Also, can you upgrade to Jetpack 1.9 which fixes a problem with Klout?

  6. Thank you for your help!

    I ran my blog through the Debug module, and it did tell me that XML-RPC seems to not be enabled. However, it is.

    Also, xmlrpc.php successfully displayed "XML-RPC server accepts POST requests only."

    So, if xmlrpc is OK, and the problem persists with a theme such as Twenty Eleven, then it must be a plugin issue?

  7. Have you tried with Jetpack 1.9 (released this morning)?

  8. I just did.
    Also, I disabled all plugins and activated Twenty Ten.
    Still the same message.

    So I'm all out of ideas :)

  9. Would you please take a screenshot of the error you're seeing, upload it via Media -> Add New in your blog's Dashboard, and provide us with the image URL so we can take a look?

  10. Ok, that's what I expected (but had hoped not) to see.

    We can't seem to post to your XML-RPC on this end either.

    Would you please ask your hosting provider if they have suddenly decided to block it?

  11. Sure thing.

    Awesome thing about my hosting provider - they're just as prompt and helpful as you guys are :)

    Lemme c now...

  12. Thanks!

  13. Well, they said that they have definitely not blocked it in any way. Also, they are willing to help out, if need be.

    Is it possible that I have somehow blocked/limited this XML RPC thing? Changed some permissions, for example? I use WSD Security, is it possible that it has modified permissions?

    WSD Security -

  14. Tried changing permissions to 666 and 777, still the same error.

  15. First, make sure you have the file set to 644.

    WSD may have altered things, but shouldn't function when it is inactive. have you already tried with that plugin deactivated?

  16. Permissions were originally set at 644, and are currently back to 644.

    I tried with all plugins deactivated and with a default theme. No luck.

    Not sure where to look anymore :) I'm in mu CPanel, looking around, but nothing comes to mind.

    Directory structure / WP installation (location) issue?

  17. What do you have the Site URL and WordPress URL set as at Settings -> General in your blog's Dashboard?

  18. Both are set to

    And I have no idea whether this matters, but:


    This is the structure I see. Actually, I also see:


    And I am not sure why I see both www and public_html in there, and whether this is normal.

  19. Sigh. I think I made a mess. Entered what appears to be a wrong URL as the WordPress URL.

    Now... to see how to fix that.

  20. To answer the first question, /www/ should just be an alias of /public_html/, so stick with /public_html/ if you can.

    As for the second, may help, though I recommend asking the folks at if you need further assistance.

  21. Ah, I fixed it already :) Thank you!

    Now I am just trying to figure out whether both URLs should be one and the same (, or one should contain more information regarding the WP installation.

    What would you recommend, based on that directory structure I gave earlier?

  22. From what you listed before, I'd say that both should be the same, but are the folks who know more about the self-hosted version of WordPress.

    We really only support blogs and Jetpack here.

  23. Thank you, you've been most helpful :)

    If I figure it out, I will come back here and post my findings. Someone else could benefit too :)

  24. You're welcome!

  25. I used some XMLRPC validator - it says things are OK...

  26. We're still getting a "page not found" for the file.

    Entering your blog's URL at should provide you with some data that you can share with your hosting provider.

  27. Oh, sorry, I forgot you couldn't see everything that I do.

    Basically, your XML-RPC file is returning a 404 not found error for us, which usually means that they're blocking it (or us) for some reason.

    Are they noticing anything in the server access logs that might help?

    Basically, try connecting Klout or Jetpack again before contacting them, so you can provide them with a specific date and time.

  28. They say the xmlrpc is just fine.
    What URL can I give them, so that they can check whether it's blocked?,

Topic Closed

This topic has been closed to new replies.

About this Topic