Is this allowed code? Highlighting text code.

  • Author
  • #158589


    I came across this code that I have used and I thought it was OK but I want to check if this is giving me the Unresponsive Script error message. BTW this code isn’t the buggy code I came across before on other pages, this is new script I’ve come across.

    IT is this:

    <span style=”background-color: #ffff00; color: #000000″ class=”linemarker-marked-line”>A </span>fizzle<span style=”background-color: #ffff00; color: #000000″ class=”linemarker-marked-line”> is simply a detonation of lower yield than designed. It does </span>not<span style=”background-color: #ffff00; color: #000000″ class=”linemarker-marked-line”> mean a dud. Wrong words leads to wrong thinking.</span>

    I got the code from Scrapbook (Firefox) which allows you to edit what you’ve scrapbooked by using this code which highlights text. I didn’t think it was a problem before but because this page is slow to load and save, I wonder if it is illegal code. It does work to highlight text in View mode, but if it’s causing loading and saving of that page to slow down, I will get rid of it. It’s no biggie. If it’s OK script, I’ll keep it.

    I have started a thread about script causing slowing down of blog page but I repeat this script is not responsible for all those problems, there is only one page that I highlight text in.

    I’ve removed code I’m unfamiliar with but I still have the slowing of loading and saving with the other pages though removing code helps a little bit.



    Another question on allowed code is:

    ‘<‘ a ref=” ……..” title=”…..” ‘>’….’‘

    Is this allowed code? This code is for links.


    hello bobtailcat,
    good day! :D
    the codes in your second posting are ok.

    and rest assure that any code that is “illegal” for will automatically be stripped by!

    about span tags, i don’t remember the exact code, but i did try posting a code that included span tags once, and they were stripped by wp.

    i don’t know about the slowness though!


    i have tested your first code verbatim in a test post. worked fine for me.
    it cretaed some highlighted text.

    could you please post the url of your other thread here as well? for the sake of cross-reference?

    thanks in advance!



    Okay, thanks for the quick reply by the other way.

    I don’t understand: certain java scripts may work but still slow down the loading of the blog page, can’t they?

    Are you sure the — <b> title=’….’ </b>— bit is OK in code for links?

    Here is the other thread where I discussed why the page took so long to open up in Edit mode and also why it took so long to save.

    Also do you know what is?

    I also see this at the bottom of the browser when opening a page for editing:


    Is this a clue as to the cause of the slowing down of the loading of the Edit page?


    in there is absolutely no way you can post javascript code – it will be stripped for security reasons.

    none of the codes you mentioned is javascript, they are pure HTML! :D

    <' a ref=" ........" title="....." '>'....''
    this code works for specifying hyperlinks.

    rel attribute describes the relationship from the current document to the anchor specified by the href attribute. The value of this attribute is a space-separated list of link types.
    more information here

    title makes a text appear when the cursor is hovered over the mouse.


    title makes a text appear when the cursor is hovered over the mouse.
    so sorry for that nonsense. {blushing}

    i meant to say:
    title makes a text appear when the cursor is hovered over a hyperlinked text (or image fpr that matter!)



    Okay, thanks for that, will have to hunt more for the javascript that is slowing things down. I thought there was overlap between javascript and HTML.

    I’ve removed ‘<‘pre’>’ and p class’…’ and that seems to have made the page load faster.


    pre could slow things down. i have it in one of my posts, and that post takes a while to load, especially the section that in between pre tags.

    will have to hunt more for the javascript that is slowing things down.
    there is no javascript to hunt in your blog. all js is automatically stripped. :D

    pre and p class are NOT javasvript. they are html.



    If there is no javascript allowed, how come I keep seeing this every now and then:


    I just saw it again. This was after I inserted a Photobucket image and then linked it to a video on Dailymotion so that if you click on the image it opens a new window to the URL it’s linked to. I don’t think this is a problem, inserting an image-URL, but I noticed a javascript message appearing in the bottom of the browser window and the error message about Unresponsive Scripts came up. I hadn’t tried to Save the page or anything. It is on ‘Published’ mode.

    It’s so weird and time-consuming because it slows my work down.

    BTW I went through the code and removed any code that might be causing problems, any code that I’m not familiar with. The only code I left in was <table > < tr > <td > code. I guess that code is OK? It works anyway. Though it could still slow things down.

    I just wish I knew what was causing the slowness of the page and that message to keep popping up. Before it used to pop up on opening or saving only, now it pops up every now and then after I’ve added text (I copied and pasted some text using the plain text function just now) or added images to it.


    no javascript allowed means we don’t have the privilege of our own javascript, it does NOT mean wp doesn’t need javascript to function. whatever javascript you are seeing is coming from the wordpress side, not due to some javascript you entered.

    i am not sure about the tinymce thing. all i can say is i had problems with tinymce when i posted images code in a post once – it kept popping up in the code. i was using internet explorer. the problem ceased when i used firefox.

    which browser are you using? maybe the unresponsive script thing happens due to the browser? i’m afraid i have no idea. :(



    Tinymce is the editor we use to write blog entries/pages. Remind me of your operating system and browser.



    My operating system is mac OSX 10.39 and I use Firefox



    Can you try upgrade to Firefox 2? Safari is known to have issues with TinyMCE. Or maybe try Camino?



    I was hoping you weren’t going to suggest upgrading to Firefox 2.0. ;) I like Firefox 1.5. I tried Camino and that wasn’t any better. I guess I’ll try different browsers and see if things improve. I might use a different browser just for WordPress and keep Firefox 1.5 open for other non-WP pages. Thanks a lot for the feedback, katm and sanjidabd.

    (Once again, I just noticed now the message about unresponsive script came when data from was loading. Perhaps this is the cause. I’ll try different browsers and check.)



    Maybe try creating a new firefox profile? Perhaps something is borked in your current one.

    I’m not sure how to start it on a Mac. I was just fooling around with starting it from a shell on Linux, but I can’t seem to get it to start opening the profile manager. Let me close this instance of Firefox and see if that lets me do it. I think you can’t already have a running instance of FF.



    At least in Linux (and as Macs have *nix under the hood) you first need to close FF. Open a shell. If Firefox is in your path, you’ll just need to do Firefox -ProfileManager If it’s not, then you’ll need to cd /path/to/your/firefox/directory and then start Firefox using ./firefox -ProfileManager

    Then go through the dialog box it pops up to create a new profile. Try that one. If your script issues go away, then you have a borked profile. You should be able to export/import your bookmarks into the new one.

    The only other thing I can think of is it might be an add-on creating issues. Try disabling all of them and see if your problems go away. If they do, add them back in one at a time to see which one is giving you issues.

    (I hope this all comes out… no preview here and no edit here anymore)



    Oh yeah…

    This page should help too

    (I miss the edit window…)


    thanks for thanking! u r most welcome! and best of luck! :D

    you rock! well, rock on! :D
    (i miss the edit button too! i am an AWFUL keyboard user AND i am often absent-minded! :(
    ah, the value of little things in our life!)



    LOL. I hardly rock. I stumble around in th dark most of the time. It took me a while to figure out how to start the profile manager on Windows. At least on Linux I can do man firefox or firefox --help from a shell and see my options.

    And for the record (or those who fine this in the search in the future), on Windows you need to do start -> run. Type “firefox.exe -ProfileManager” without the quotes. Hit enter.

The topic ‘Is this allowed code? Highlighting text code.’ is closed to new replies.