Need help? Check out our Support site, then

Is wordpress slow only for me?

  1. I'm in Brunei and WordPress is excruciatingly slow. My friends have reported the same so I know I'm not alone. Am running Firefox 7.0.1, Windows 7, and is normally pretty fast but has been very slow with occasional time-outs for a few days now. Editing a post sometimes just freezes. In contrast, Facebook run fasts as do general browsing of other sites.

  2. i had problems over the weekend and notice today i have no referrers which is very odd. first time i can recall that ever happening.

  3. @macmanx Thanks!

    Thanks for looking into it.

    Current situation: I can ping, and it opens from the browser. Traceroute, however, still stuck at the last hop ( OS X's traceroute uses UDP packets by default. When I try ICMP, it works well:

    <br /> $ traceroute -I<br /> traceroute to (, 64 hops max, 72 byte packets<br /> ...<br /> 5 ( 15.934 ms 18.097 ms 15.331 ms<br /> 6 ( 66.819 ms 61.288 ms 51.821 ms<br /> 7 ( 37.530 ms 32.749 ms 29.709 ms<br /> 8 ( 51.389 ms 50.550 ms 51.465 ms<br /> 9 ( 72.547 ms 51.120 ms 58.081 ms<br /> 10 ( 51.185 ms 51.941 ms 51.178 ms<br />

    Not sure what's the deal with UDP packets, as previously it worked, so maybe it's not related after all.

    Connection issues with happen only occasionally. I will post into this thread if we'll notice them again. If you're interested (and if some DoS protection don't block me), I can setup a script to periodically (e.g. every 5 minutes) try to get something from this server by HTTP, run it for a day or so, and tell you how often it fails.

  4. Seen this again today. Quickly jumped to various tests:

    curl --head timed outed.
    traceroute (UDP) stuck at last node, as mentioned.
    traceroute -I (ICMP) succeeded.

    A few seconds later it came back (except for UDP traceroute).

  5. #chestnykh

    It looks like the UDP timeout problem is likely unrelated. can you provide the HTTP response headers from a successful request? Thanks - the Edgecast folks are monitoring this thread and awaiting your reply.

  6. @barry

    <br /> $ curl --head<br /> HTTP/1.1 200 OK<br /> Accept-Ranges: bytes<br /> Content-Type: text/html; charset=UTF-8<br /> Date: Mon, 14 Nov 2011 22:30:03 GMT<br /> Last-Modified: Fri, 11 Nov 2011 22:57:53 GMT<br /> Link: <>; rel=shortlink<br /> Server: ECS (lhr/4B8C)<br /> X-Cache: HIT<br /> X-hacker: If you're reading this, you should visit and apply to join the fun, mention this header.<br /> X-Pingback:<br /> Content-Length: 13830<br />

  7. hey guys!

  8. @chopsoi
    Hello there,
    Just to be clear, on these support forums we only post to wither ask for specific help or to answer those who are asking for specific help. How can we help you?

  9. edit: "wither" was meant to be "either"

  10. hey guys!
    i set up my blog last week and it was working perfectly fine up until two days ago. not just my blog, in general went turtle speed.
    it just works (sometimes) after i clear my cookies and restart firefox, but even then i have to log in again and once i do that and try to post anything or just go to my dashboard it gets cranky again, so its not realy working.
    i am running firefox 7 on windows 7 with a pretty good connection speed.
    im in portugal, i notice that maybe this is a region problem (london/uk servers?)..

    thanks :)

  11. am running firefox 7

    You could upgrade your outdated browser and see if that helps. You can upgrade any browser version here.

  12. oh, very sorry.
    well i wanted to know what can i do to make my dashboard work, or if there is something i can do, because im going away for a few months and i wanted to set up my post in advance, so if even if i can't access the internet it will be posted anyway.
    also just wanted to say that im having the same problem .

    ps. now i just noted my post saying hy. thats because the website froze when i was writing and somehow posted just that while i was writting. sorry i didnt meant for that to happen, its just wordpress is realy beeing funky on me.

    thank you for understanding, sorry about the trouble.

  13. I'm sorry that happened to you above. I misunderstood and I apologize. The blog linked to your username is empty. Will you please post and active link to the blog in question starting with http:// ?

    Will you please provide us with some details so we can try to help you?

    1. How are you connecting to the internet and to The way you connect to the internet (mobile, satellite, DSL, dial-up) and to your blog, and how many proxy server jumps etc. it takes to connect can cause problems. There maybe be problems with your ISP and/or with the proxy servers.

    2. Are you using http:// or https:// see

    3.Which browser and version of it are you using?

    4. Have you tried clearing your browser cache and cookies?

    5. Is your browser version up to date? You can upgrade any browser version here.

    6. Do you have third party cookies enabled?

    7. Do you have JavaScript enabled?

    8. Do you have another browser you can try?

    9. You can use this link to see if your Flash is up to date. If it’s not up to date then this is where to download and install the latest version of Flash.

    10. Have your tried resetting your router and modem?

    11. Have you had any recent operating system and/or security program updates?


    this is my blog.
    hmm.. ok so im using http
    i tried on explorer and chrome and nothing changed, javascript is enabled, flash is up to date. i did restart my browser (i just updated it to the last version of firefox 8... but to no avail, even this page is only half loaded), i didnt have nay recent problems with my os nor did i make any upgrades, cookies are enabled.
    again i clear the cookies and it works better sometimes but just to open my blog page and when i login i can't do much else.

    so after all this i guess i can be a problem of my ISP? but about this i have no idea how to proceed, not very knowledgeable in that area. all i know is that its a dsl connection (good one) and that i dont know how to see how many proxy i jump.

    thank you again :)

  15. It sounds like there could be a problem with your ISP.

    Can you access any of these directly?

  16. one time. it took a long time but they opened. i tried then accessing my dashboard, its sitll loading but all blank, and after i refreshed the sX.wp links i had the "connection has timed out"..

  17. I'm going to flag this thread for Staff attention. Please be patient while waiting for a reply.

  18. Can you please run a traceroute to the URLs that timethief listed and send us the results?


    Tracing route to []
    over a maximum of 30 hops:

    1 1 ms 1 ms 1 ms
    2 * * * Request timed out.
    3 37 ms 27 ms 35 ms []
    4 43 ms 23 ms 35 ms []
    5 67 ms 100 ms 89 ms
    6 80 ms 74 ms 106 ms
    7 73 ms 85 ms 89 ms []
    8 85 ms 86 ms 101 ms

    Trace complete.

    Trace complete.


    Tracing route to []
    over a maximum of 30 hops:

    1 1 ms 1 ms 1 ms
    2 * * * Request timed out.
    3 372 ms 375 ms 362 ms []
    4 435 ms 443 ms 473 ms []
    5 518 ms 543 ms 567 ms
    6 84 ms 83 ms 89 ms
    7 72 ms 92 ms 83 ms []
    8 85 ms 94 ms 99 ms

    Trace complete.


    Tracing route to []
    over a maximum of 30 hops:

    1 2 ms 2 ms 2 ms
    2 * * * Request timed out.
    3 32 ms 35 ms 28 ms []
    4 42 ms 35 ms 59 ms []
    5 87 ms 94 ms 92 ms
    6 92 ms 72 ms 99 ms
    7 106 ms 97 ms 98 ms []
    8 116 ms 117 ms 91 ms

    Trace complete.

    its been working on and off for a while now.but whenever i start to write a post, the moment i try to insert a picture or change color in the lettering just keeps on loading forever.

  20. At Users -> Personal Settings in your Dashboard, is "Always use HTTPS when visiting administration pages" checked?

    If not, would you please try with it checked?

  21. omg.. it seems to be working yes thank you very much!! sorry to have kept you all this time

    changing to https worked for now :)

    thank you very again! i can finally get my posts together :)

  22. Excellent, that's great to hear!

  23. @chopsoi
    Woo hoo! So happy to hear you have resolved this. That was my second troubleshooting tip above.

    2. Are you using http:// or https:// see

  24. @timethief
    thank you very much for the support! i know im sorry, i just couldn't open the page before so i didn't really know where to change that... :P
    thank you for the support!


  25. You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Topic