Why aren't Jetpack/Sharedaddy buttons appearing on all pages?

  • Author
    Posts
  • #700830

    Hi,

    I use JetPack plugin now and I have a bug with Sharedaddy included:

    On the configuration page of this module I have choose to display share links on pages, posts, and home page but I see links only on home page. No on page and posts.

    An idea?

    Thanks for your help :)
    Blog url: http://www.lapommecroquee.com

    #700994

    evarlese
    Staff

    Hi there,

    Can you let me know what version of Jetpack you’re using?

    Additionally, can you go to your site’s Dashboard -> Settings -> Sharing and ensure that all of the Share buttons that you would like to appear on your site are in the “Enabled Services” module?

    Similarly, in the drop-down menu next to “Show sharing buttons on,” can you confirm that “Posts, pages, and index pages” is selected?

    #701033

    Hi,

    I use the version 1.1.3 of JetPack extension.

    I confirm that:
    – All of the Share buttons that I would like to appear on my website are in the “Enabled Services”
    – In the “Show sharing buttons on” I have selected: “Posts, pages, and index pages”

    If you want to see: http://cl.ly/2h251v13102C0q1D102T

    Regards,

    #701072

    macmanx
    Staff

    Would you mind temporarily switching to the Twenty Eleven theme? I’d like to rule-out a theme-specific issue.

    #701082

    Hi,

    I have tested with the preview mode of theme manager and Twenty Eleven and I have the same problem.

    Buttons are displayed only on the home page but not on the post page: http://cl.ly/213e2a3q1u2d393p233m

    Thanks for your help,
    Regards.

    #701085

    macmanx
    Staff

    Please try editing the specific post. Are the sharing buttons disabled for that post? You should see a checkbox near the bottom of the edit page.

    #701091

    I confirm that that the checkbox for a specific post is enabled: http://cl.ly/3O102v3Z220o2O3A0U1O

    #701092

    macmanx
    Staff

    Is there any improvement if you temporarily disable all other plugins?

    If so, can you tell us what plugins you’re using?

    #701093

    I disabled all plugins and I reactivated one by one to check which is in conflict and found. As soon as I enable Simple Facebook Connect (http://wordpress.org/extend/plugins/simple-facebook-connect/) Jetpack buttons no longer appear on the articles.

    Do you know why ?

    #701094

    macmanx
    Staff

    It’s probably because of the Sharing button or Like button element conflicting with the very same button that Jetpack would add.

    If you disable those modules in SFC, is there any improvement?

    #701095

    The only module in SFC that I use is “Publisher (send posts to Facebook)”

    #701096

    macmanx
    Staff

    This would have definitely been solved in the earlier version of SFC by just not activating SFC’s sharing plugin, but now that they’re modules under one plugin, that should have worked the same.

    I recommend contacting the developer of SFC about this, maybe there’s something lingering after the module is deactivated.

    #701097

    I have contacted the dev of SFC and this is the response:

    ShareDaddy is broken. I’ve reported this upstream, but they have yet to fix it.
    In the /jetpack/modules/sharedaddy/sharing-service.php file, on line 400, you’ll find these three lines of code:
    // Only show once
    if ( isset( $shared_with_posts[$post->ID] ) )
    $show = false;

    Remove those lines and ShareDaddy will work properly.
    Feel free to point out this to them. Also tell them to read this article, because ShareDaddy is yet another plugin that is doing-it-wrong:
    http://ottopress.com/2011/actions-and-filters-are-not-the-same-thing/

    #701098

    And he say:

    Filters should not have unexpected side effects, and that includes only working one time.

    #701101

    macmanx
    Staff

    Otto sent me an email with pretty much the same, so I have forwarded it on to our team for consideration.

The topic ‘Why aren't Jetpack/Sharedaddy buttons appearing on all pages?’ is closed to new replies.