Jetpack conflict with simple URLs plugin?

  • Author
  • #692655


    I want to use the StudioPress Simple URLs plugin which uses custom post types for URL redirection, however when trying to add or update a Simple URLs entry, the publish/update button had no effect – the activity indicator next to the button does not appear and the entry is not published or updated.

    I suspected a plugin conflict so by a process of elimination I have identified that this issue occurs when Jetpack is active. After deactivating Jetpack the problem disappears and I can save Simple URLs entries, but when jetpack is active the issue comes back.

    I posted to the StudioPress forum to report the issue and the reply to my post was:

    “The part of Simple URLs where you save/publish a URL is native WordPress code. If you want to keep using JetPack you’ll have to contact the them and see if they can resolve the issue.”

    All other plugins I have tried seem to work fine with Jetpack and Simple URLs seems to work fine with all plugins I have tried except for Jetpack, so there appears to be a conflict somewhere between the two, however I have so far been unable to locate the cause.
    Blog url:



    Hi there,

    We’re taking a look into this issue. I will be sure to provide you with an update as soon as possible!



    Hm – I was unable to reproduce the problem. I have a bunch of questions which should help us figure out what’s going on.

    What browser are you using?

    What version of WordPress is your site running?

    What version of the Jetpack plugin?

    Do you know how to access your browser’s Javascript Error Console? If so, when you click Simple URL’s save button, does any error appear in the error console?

    Does the problem happen when the Jetpack plugin is active, but you have not yet clicked Jetpack’s “Connect to” button?

    After you click the “Connect to” button, try deactivating all of the Jetpack features. You can deactivate each Jetpack feature by clicking on each feature’s “Learn More” button, then clicking the “Deactivate” button that appears next to the “Learn More” button (confusing, I know). After all the features are deactivated, does the Simple URL problem still occur?

    Thanks for helping us get to the bottom of this bug.



    Thanks for the responses.

    To answer your questions, mdawaffe:

    I’m using Firefox 6 Mac, but I also see the issue on the other browsers I have tried including Safari 5.1 on Mac & Safari on iPhone.

    WordPress is at version 3.2.1

    Jetpack is version 1.1.3

    I have set up a clone of my site at a different domain and deactivated all plugins excerpt for Jetpack & Simple URLs. I am seeing the same issue on this installation

    On the Simple URLs admin page with the js error console, on pressing the [publish] button, the error returned is:

    [13:40:55.774] jQuery("#content").val() is undefined

    The error is associated with

    The problem goes away when Jetpack is disconnected from, and reappears after reconnecting.

    Thanks for the useful tip about deactivating single features in jetpack. Using that I have found that the problem only occurs when the ‘After the Deadline’ component is active.

    As Simple URLs sets up a custom post type without an ‘editor’ (content) metabox, I wonder whether After the Deadline is attempting to check something which doesn’t exist?

    As I have a clone of my real site for testing, I am happy to perform any further tests with no fear of breaking anything.



    Thanks for the reply, numeeja. I’ve managed to reproduce the error now.

    We’ll have a fix for this in the next version of Jetpack.

    In the meantime, if you want to use the After the Deadline feature:

    1. Reactivate it.
    2. Go to your blog’s admin → Users → Your Profile.
    3. Under the Personal Options → Proofreading, uncheck both the “Automatically proofread content when: a post or page is first published” and “a post or page is updated” checkboxes.

    AtD Options.png



    Thanks mdawaffe.

    Unchecking those options has solved the issue for me and is a good workaround.

    I’ll look forward to seeing the next version of Jetpack.

The topic ‘Jetpack conflict with simple URLs plugin?’ is closed to new replies.