Need help? Check out our Support site, then

Jetpack connects to wrong site

  1. When I connect Jetpack to WordPress, it connects to an old archived version of my site ( rather than the main domain ( - how can I fix this?
    Blog url:

  2. What two URLs (Site and Home) do you have set at Settings -> General in your blog's Dashboard?

  3. I have the main domain ( set in Settings. The old site (, which Jetpack keeps connecting to, doesn't even exist as a WordPress site anymore - its an html archive of the old posts...

  4. Ok, let's try this.

    First, deactivate, then delete the Jetpack plugin.

    Once you have done that, let me know, I'll make a tweak on this end, and you can try installing again.

  5. Done :)

  6. Ok, please try installing and connecting Jetpack now and let us know how it goes!

  7. Nope, no joy - I still get the old 2009 stats (not the stats I see with the old WPStats plugin)...

    (btw, I tried to rate the service using the links in the email notifying me about the reply, but I get to a 404)

  8. I don't even see the new domain registered on your account now. Did you connect to your gillespieza account, or a different account?

  9. Gillespieza ....

  10. What is the URL of the actual blog? doesn't appear to be it.

  11. No, that is correct: Maybe I'm in the wrong forum - this is a self-hosted WP site, but the Jetpack help/support page led me here?

  12. We do support Jetpack here, I just have absolutely no Jetpack connections in our system for, which would be impossible if you did infact re-connect it.

    Did you completely delete the plugin through the Dashboard earlier? This is the only way to clear its settings.

  13. I deactivated and then deleted, then searched for Jetpack to re-add when you said go... I also deactivated the old plugin as well ...

    When I reconnected Jetpack, it confirmed I was connecting to my WordPress account... Let me try it one more time

  14. Deactivated and deleted again, and I went in to my site's FTP and double-checked that the Jetpack folder was gone (and also the old WordPress Stats plugin as well, just for good measure)... I didn't check whether the tables were removed from the database though...

  15. Hm, it came through as again. Frustrating for sure.

    However, I finally found an orphaned listed for, so I added it to your account.

    Once more, would you please try deactivating, deleting, then reinstalling and connecting Jetpack?

    Fingers crossed for sure this time.

  16. No luck - still getting the stats...

  17. Well, that's no good then. I'm going to have to pass this up to the big guns. Please hang in there, and I'll let you know as soon as I hear something.

  18. Hi gillespieza,

    I'm sorry Jetpack isn't working for you. Unfortunately, We don't know what's going on :) To figure it out, we need some more information about your site. Some of that information is sensitive, though; it'd be bad to post that information here, so I sent you an email from our support service with some questions.

    Hopefully, we'll sort everything out soon.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.