Jetpack subscription error when posting a forum topic in Buddypress

  • Author
    Posts
  • #891373

    I’m having a problem posting new forum posts in buddypress and it seems to be an off and on again problem. After posting a new topic post I get this message:

    Warning: Missing argument 3 for Jetpack_Subscriptions::save_taxonomy() in …public_html/wp-content/plugins/jetpack/modules/subscriptions.php on line 91

    Warning: Missing argument 3 for Jetpack_Subscriptions::save_taxonomy() in …public_html/wp-content/plugins/jetpack/modules/subscriptions.php on line 91

    Warning: Missing argument 3 for Jetpack_Subscriptions::save_taxonomy() in …public_html/wp-content/plugins/jetpack/modules/subscriptions.php on line 91

    Warning: Missing argument 3 for Jetpack_Subscriptions::save_taxonomy() in …public_html/wp-content/plugins/jetpack/modules/subscriptions.php on line 91

    Warning: Cannot modify header information – headers already sent by (output started at …public_html/wp-content/plugins/jetpack/modules/subscriptions.php:91) in ..public_html/wp-includes/pluggable.php on line 866

    I didn’t have the subscriptions widget enabled. So I tried turning it on, but the problem was still happening. After getting this error if I go back and refreash the page the forum post shows up. But it doesn’t get pulled into the site activity stream. I’m guessing because of the error in Jetpack when processing it.

    How can I fix this?
    Wordpress 3.3.2
    Buddypress 1.5.5
    Thanks!
    Blog url: http://homestead-acres.com/

    #891627

    macmanx
    Staff

    Hm, that shouldn’t be happening. Which version of Jetpack are you running?

    #891629

    Jetpack is version 1.3

    #891643

    macmanx
    Staff

    Thanks for confirming!

    We’re looking into this.

    #891656

    Thanks! I’ve been trying a few posts today and it seems to happen more often if there is a link placed into the forum topic message.

    #891657

    This is going to be a tricky one to fix. It’s actually neither BuddyPress nor Jetpack directly causing this, but a bit of code that BuddyPress’s forums depend on.

    Until we can figure out a fix, the only easy solution I have is to temporarily turn off Jetpack’s Subscriptions. I’ll be looking into this personally, and will have follow up here in the next 24 hours.

    #891684

    Thanks for looking into the problem so quickly. I turned the subscriptions off in the mean time.

    #891690

    macmanx
    Staff

    Thanks, we’ll let you know as soon as we have something.

    Sorry for the trouble!

    #891696

    General update: We’re looking into putting a fix directly into Jetpack to try and circumvent this notice; I’ll follow up with more detailed results once they’re available.

    #891727

    This will be fixed in the next release of Jetpack. Thanks for letting us know, and thanks for your patience too!

    #891756

    Thank you! Everything is working well now. :)

    #891761

    Hey guys, I’m having trouble with this again. :( I’ll try to be brief. When you released the update for this problem I did update and it worked great! The buddypress forum posts went through ok and were sent to the activity stream.
    But there was another update not long after this one and it’s caused the forum topics to stop being sent to the bp activity stream again. BUT it doesn’t seem to post an error notice. I’m sure it’s jetpack causing the problem. I had updated no other plugins at the time. I would have posted sooner but have been a way on an off.
    Today I upgraded to WP 3.4.1 and BP 1.5.6 and Jetpack 1.4.2 hopping that would fix the problem, but it didn’t.

    Also when in the buddypress activity stream if you change the filter box from everything to forum topics the last forum post it shows was 2 weeks ago. There have been posts made sooner than that. If they don’t get sent to the activity stream, most members miss seeing them. Now the replies to the forum posts seem to get sent through to the activity stream ok.

    #891762

    macmanx
    Staff

    Sorry about that, we’re looking into this!

    #891763

    Have you had any luck figuring out the problem? My forums are still unusable because it will not send the post into the BP activity stream. :( It has to be something that changed between the two Jetpack versions, because you guys fixed it that other time.
    I really don’t want to have to uninstall Jetpack, I love it for my stats!

    #891764

    macmanx
    Staff

    Sorry for the delay, they’re still looking into it.

The topic ‘Jetpack subscription error when posting a forum topic in Buddypress’ is closed to new replies.